PCBnew Hangs if tracksize == 0

Bug #1804834 reported by Michele Giorato on 2018-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Maciej Suminski

Bug Description

This is quite annoying because if, by mistake, you enter 0 as track thickness, you will see a lot of requester in sequence that is impossible to cancel and that take all the time of the CPU.
The only solution is to kill the kicad process with consequent loss of work in progress.

See attached picture

Application: kicad
Version: 6.0.0-rc1-unknown-r14474-ae6989f3, debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.59.0 OpenSSL/1.1.0i zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh/0.8.5/openssl/zlib nghttp2/1.32.1
Platform: Linux 4.19.2-200.fc28.x86_64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.66.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.59.0
    Compiler: GCC 8.2.1 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Michele Giorato (mr-miky64) wrote :
Changed in kicad:
importance: Undecided → High
status: New → In Progress
assignee: nobody → Maciej Suminski (orsonmmz)
milestone: none → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 056114a15d19b1973bbc26e18b194e1425910833
https://git.launchpad.net/kicad/patch/?id=056114a15d19b1973bbc26e18b194e1425910833

Changed in kicad:
status: In Progress → Fix Committed
Michele Giorato (mr-miky64) wrote :

The patch is not really the best.
It is true that all the burst requester no longer appears, but something does not fit with the net / filter.

If the thickness of the trace remains 0 and you try to change net it happens that the requester of too low thickness ends up under the net list and everything becomes irresponsible because it is waiting for the OK (hidden) for the thickness problem.

Is it not the case that after the notification of a thickness that is too low, the thickness itself is automatically set to the minimum permissible value rather than leaving it at 0?

Michele Giorato (mr-miky64) wrote :

Perhaps it is better to set the thickness to the minimum acceptable by the rules set on the pcb?

Maciej Suminski (orsonmmz) wrote :

Personally I am against modifying any settings without the user consent, the decision should be taken thoughtfully.

I have managed to reproduce the described behavior, but I do not have a good idea for the solution yet. Perhaps instead of a dialog box there could be a text label displayed next to/under the problematic field.

Changed in kicad:
status: Fix Committed → New
status: New → Triaged
Michele Giorato (mr-miky64) wrote :

me too, but 0.0001 I would set it after the warning message ...

Michele Giorato (mr-miky64) wrote :

Even if it automatically set it at 0.001, nothing serious happens since the DRC signals it for sure.
It would probably be more dangerous if you set it to the minimum allowed by the rules of the pcb and then it could happen that the pcb passes the drc rules without the user being aware of the variation introduced

Jeff Young (jeyjey) wrote :

This should be fixed by the recent removal of auto-validation on KillFocus.

Changed in kicad:
status: Triaged → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers