PCBnew crashes randomly

Bug #1803978 reported by Julian Schneider on 2018-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
Undecided
Unassigned

Bug Description

I'm on windows 10x64 and have KiCad 5.0.1 installed.

The kicad pcb tool crashes when I delete a filled zone and on some other occasions without any other error.

Application: kicad
Version: (5.0.1)-3, release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

description: updated
Nick Østergaard (nickoe) wrote :

Please test with the latest build named 5.0.1_4.

tags: added: packaging pcbnew windows
Changed in kicad:
status: New → Incomplete
Julian Schneider (juledev) wrote :

Tested with
Application: kicad
Version: (5.0.1)-4, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Still breaking.

Nick Østergaard (nickoe) wrote :

Please add test file.

Julian Schneider (juledev) wrote :

Tested with same version on ubuntu, does not throw an error, seems to be a windows issue. Will post test file when back on windows.

What do you mean by "does not throw an error"
Have you some warning/error dialog on Windows, or just a crash?

Julian Schneider (juledev) wrote :

Sorry, it simply crashes.

Wayne Stambaugh (stambaughw) wrote :

I suspect this has already bee fixed for 5.0.2. If possible please test the 5.0.2 pre-release at http://downloads.kicad-pcb.org/windows/testing/5.0/ and report back if the issue still occurs.

Julian Schneider (juledev) wrote :

File attached, try deleting the zone on the front under the mosfets on the right.
Version 5.0.2 I will try later, download is super slow right now.

Julian Schneider (juledev) wrote :

Application: kicad
Version: (5.0.1-42-g03132cabe), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Does not fix the issue

Wayne Stambaugh (stambaughw) wrote :

I cannot duplicate this with attached file when deleting the zone using the head of the 5.0 branch (5.0.1-44-g50eedcf0b) so I'm changing the status of this bug report to fix committed. If someone can reproduce it, please set the status back to new.

Changed in kicad:
status: Incomplete → Fix Committed
Gabriel Staples (ercaguy) wrote :

I'm installing the latest Windows Stable 5.0.1 KiCad version into a Windows 10 64-bit VirtualBox system right now to see if the bug is present, but I already have the nightly installed there. It looks like I cannot have both the Windows nightly and Windows stable versions installed simultaneously, like I can on Ubuntu? Or if I can, how? When I go to install the stable version it says:

"KiCad is already installed. Installing this package will overwrite existing files. Do you want to continue?"

Gabriel Staples (ercaguy) wrote :

I don't see the bug either.

Application: kicad
Version: (5.0.1)-4, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

I deleted the zone on the right with no issue. No crashing. It does indeed look like the bug is fixed.

Note: I was able to install both KiCad 5 stable and nightly simultaneously in Windows 10. I simply installed to a new folder ("C:\Program Files\KiCad_Stable") instead of "C:\Program Files\KiCad", and I renamed my desktop shortcut before-hand so it wouldn't get over-written. Both seem to work together on Windows just fine now.

Julian Schneider (juledev) wrote :

See comment #2. Must be related to my configuration somehow

Julian Schneider (juledev) wrote :

Are there any additonal logs or debug modes I can enable to fix the issue?

Seth Hillbrand (sethh) wrote :

@Julian-

When you say it crashes, can you say more about what that looks like? Does the window disappear? Does it say "Not Responding" first? Does Windows give you an error window after?

In your system logs, can you copy and paste here the messages about KiCad?

Julian Schneider (juledev) wrote :

I installed the nightly but that was lagging incredibly, so I went back to the newest stable. I was able to use it for a while before it crashed again. A Crash is a short freeze and then the program exiting completely. Here is the event log from windows events log:

Faulting application name: kicad.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: _pcbnew.kiface, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00000000006a2840
Faulting process id: 0x3958
Faulting application start time: 0x01d4863b33559b78
Faulting application path: C:\Program Files\KiCad\bin\kicad.exe
Faulting module path: C:\Program Files\KiCad\bin\_pcbnew.kiface
Report Id: 77d8b0e7-ffc0-4af3-83d1-be3e1998fd48
Faulting package full name:
Faulting package-relative application ID:

Maciej Suminski (orsonmmz) wrote :

Julian, do you recall what was the operation that caused KiCad to crash? Do you notice any pattern?

Julian Schneider (juledev) wrote :

In the first example (the one i uploaded) it was deleting a zone. The last time was deleting something else I believe, though I'm not a 100% sure.

Seth Hillbrand (sethh) wrote :

@Julian-

Do you maintain other copies of KiCad on your machine?

Can you say how you are installing KiCad?

Wayne Stambaugh (stambaughw) wrote :

@Julian, do you mean the nightly download was lagging or used the nightly build and it was lagging. There shouldn't be any reason the nightly build performance would significantly different from the the current stable version. However, there are a few bug fixes that may resolve your crash issue which is why I wanted you to test it to determine if this issue is already resolved.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers