Pcbnew: Clicking inside smd footprint shows "clarify selection" menu

Bug #1803803 reported by Fabián Inostroza on 2018-11-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
jean-pierre charras

Bug Description

- Open Pcbnew and add an SMD footprint (ex: LQFP-64)
- Click inside the footprint
- The clarify selection menu is shown listing some pins

You can also reproduce by opening the footprint in footprint editor.

Application: kicad
Version: (6.0.0-rc1-dev-1212-g208622699), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 GnuTLS/3.5.19 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.34.0 librtmp/2.3
Platform: Linux 4.18.0-2-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

John Beard (john-j-beard) wrote :

If haven't had time to do a full bisect here, but it's come in since 8c8ccf83e.

Changed in kicad:
milestone: none → 5.1.0
Changed in kicad:
status: New → Fix Committed
assignee: nobody → jean-pierre charras (jp-charras)
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers