Crash when clicking OK after assigning a new footprint in the symbol properties dialog

Bug #1802641 reported by Nick Østergaard on 2018-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Critical
Maciej Suminski

Bug Description

Eeschema crash when clicking OK after assigning a new footprint in the symbol properties dialog (E hotkey).

It does not cash when I update the footprint via the Edit footprint field dialog (F hotkey).

It happens always, and on multiple projects, even the pic_programmer demo project. I have also attached a backtrace.

How to reproduce:
1. Open any project, for example the pic_programmer.pro
2. Start eeschema from kicad
3. Hit E over a symbol, for example U4 in the pic_programmer.sch
4. In the footprint field, click the book/library icon, this open the footprint selector thing
5. Select a other footprint
6. Click the "Insert footprint into board" icon
7. Click OK --> Crash happens

Application: kicad
Version: (6.0.0-rc1-dev-1168-gacfa13c03), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.62.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.34.0
Platform: Linux 4.18.16-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.68.0
    Curl: 7.62.0
    Compiler: GCC 8.2.1 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Nick Østergaard (nickoe) wrote :
Jeff Young (jeyjey) wrote :

I can't reproduce on OSX. GTK-specific?

Maciej Suminski (orsonmmz) wrote :

Tried both GTK2 and GTK3, no luck here. Can you get us a stacktrace?

Changed in kicad:
status: New → Incomplete
Nick Østergaard (nickoe) wrote :

@Maciej, I already did attach a backtrace. Do you need more details?

Nick Østergaard (nickoe) wrote :

Ok, I did a couple of new builds, one for gtk2 and gtk3. It looks like it only segfaults with gtk3.

I am using Archlinux and is using:

extra/wxgtk-common 3.0.4-2
    Common libraries and headers for wxgtk2 and wxgtk3
extra/wxgtk2 3.0.4-2
    GTK+2 implementation of wxWidgets API for GUI
extra/wxgtk3 3.0.4-2
    GTK+3 implementation of wxWidgets API for GUI

I will attach my CMakeCache.txt files

Nick Østergaard (nickoe) wrote :
Nick Østergaard (nickoe) wrote :
Nick Østergaard (nickoe) wrote :

/usr/lib/libgobject-2.0.so.0 is owned by glib2 2.58.1+67+g17519e039-1

Nick Østergaard (nickoe) wrote :

extra/gtkmm3 3.24.0-1 [installed: 3.22.3-1]
    C++ bindings for GTK+ 3

Maciej Suminski (orsonmmz) wrote :

Thanks Nick, I see the crash after wxgtk update. Actually it is not necessary to select a new footprint, I just open and close the symbol properties dialog.

Changed in kicad:
status: Incomplete → In Progress
assignee: nobody → Maciej Suminski (orsonmmz)
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 44424dcbb32b22506761c2a992b3868c5835ca4e
https://git.launchpad.net/kicad/patch/?id=44424dcbb32b22506761c2a992b3868c5835ca4e

Changed in kicad:
status: In Progress → Fix Committed
Nick Østergaard (nickoe) wrote :

OK, cool. Thank you. I will report back if your fix does not fix it :)

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers