Gerberview doesn't show some pads in copper layers

Bug #1801923 reported by Song Qiang on 2018-11-06
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
High
jean-pierre charras

Bug Description

I was designing a simple interface board, and after generate gerber file, I used gerberview to check it as usual, but found that only the first pad of the footprint: IDC-Header_2x07_P2.54mm_Vertical showed up. I checked the footprint and pad properties, they all say 'All copper layers'. And when I import these gerber files into CAM350, all pads of footprints showed up.
I'm thinking this may be a gerberview bug.

I'm using a Ubuntu 18.04 and built KiCAD from source and my version information is as follows:

Application: gerbview
Version: (6.0.0-rc1-dev-1119-gd465af65a), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.58.0 GnuTLS/3.5.18 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-39-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.58.0
    Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Song Qiang (cybertale) wrote :
description: updated
description: updated
affects: kicad → ubuntu
Song Qiang (cybertale) wrote :
affects: ubuntu → kicad
Nick Østergaard (nickoe) wrote :

It looks like they load fine in the 5.0 branch on windows.

Application: gerbview
Version: (5.0.1-29-g839ade2c0), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

tags: added: gerbview
Changed in kicad:
milestone: none → 5.1.0
Song Qiang (cybertale) wrote :

Hi Nick,

Thanks for the reply,

I also have a v5.0.0 installed on my windows laptop, I just checked it and it also works fine.
And I think the milestone should be 5.0.1 instead of 5.1.0.

John Beard (john-j-beard) wrote :

I see this too at 6.0.0-rc1-dev-1142-gbec2920f1 (only in GAL mode). Pads still show up in outline mode, and the D-Codes are shown.

John Beard (john-j-beard) wrote :

That is: only OpenGL GAL mode, the fallback mode is OK.

Wayne Stambaugh (stambaughw) wrote :

I confirmed this with 6.0.0-rc1-dev-1142-gbec2920f1.

@Song, this only affects the development branch so 5.1.0 is the correct milestone.

Changed in kicad:
status: New → Triaged
importance: Undecided → Low
Song Qiang (cybertale) wrote :

Hi John,

I checked with mine, and those pads show up in fallback mode. I can use fallback mode for now, thanks!

Song Qiang (cybertale) on 2018-11-06
summary: - Gerberview doesn't show some pads in cupper layers
+ Gerberview doesn't show some pads in copper layers
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision ffe4b745dd118a19e66d32931baae29cf5bc2240
https://git.launchpad.net/kicad/patch/?id=ffe4b745dd118a19e66d32931baae29cf5bc2240

Changed in kicad:
status: Triaged → Fix Committed
assignee: nobody → jean-pierre charras (jp-charras)
Changed in kicad:
importance: Low → High
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers