Footprint editor "add library" not working

Bug #1801528 reported by Rene Poeschl on 2018-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Jeff Young

Bug Description

It is not possible to add an existing lib using the "Add library" functions in the footprint editor (File menu entry or right click context menu)

Both open up a dialog similar to a file browser. I can browse to the footprint library. The browser opens the .pretty directory if i select the library i want to add instead of telling the footprint editor that this is the path to be added. (When i am in the .pretty folder i am stuck. Clicking open does nothing. Cancel does what is expected.)

Rene Poeschl (poeschlr) wrote :

Tested in both fedora (43 day old nightly) and windows 7 (nightly downloaded today)

Jeff Young (jeyjey) wrote :

OSX uses a single file dialog for both files and directories (since it doesn't need double-click to open a folder). Not so on Windows and GTK.

I've implemented an alternate for MSW and GTK, but of course I'm unable to test it. If someone could give it a spin there that would be great.

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: New → In Progress
milestone: none → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 589e1f6a96455f79b56dde7c65813919face55f6
https://git.launchpad.net/kicad/patch/?id=589e1f6a96455f79b56dde7c65813919face55f6

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers