Magnetic pads don't work anymore in other than routing mode

Bug #1801377 reported by eelik on 2018-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Medium
Seth Hillbrand

Bug Description

I don't know if it's accidental or on purpose after snapping points was introduced, but Magnetic pads: always doesn't work anymore in other than track tool. I already filed a report about snapping points not snapping, but right now it's impossible to set e.g. User origin to the center of a pad in Measure tool mode.

Seth Hillbrand (sethh) wrote :

Nope, not intentional just haven't finished the dialogs for this yet.

Changed in kicad:
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Seth Hillbrand (sethh)
milestone: none → 5.1.0
Jeff Young (jeyjey) wrote :

@Seth, did this get finished up?

Seth Hillbrand (sethh) wrote :

Not yet. Now that 5.0.2 bugs are quashed, I can spend a bit of time on it.

eelik (eelik) wrote :

I haven't missed this since the snapping points bug was fixed because the centers of pads work as snapping point.

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 05483a06c61ebc1282d5bc197c54bb2747655971
https://git.launchpad.net/kicad/patch/?id=05483a06c61ebc1282d5bc197c54bb2747655971

Changed in kicad:
status: Triaged → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers