It's impossible to set the Grid origin graphically to certain point

Bug #1801373 reported by eelik on 2018-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Seth Hillbrand

Bug Description

When the Grid origin tool is selected the cursor doesn't snap to grid or anything else. It's practically impossible to set the grid origin to some wanted coordinates. It can be done in a very tedious way by copying x and y coordinates and setting them as text in Grid Settings but I would prefer having the ability to snap to important points (centers of pads and footprints). Otherwise the Grid origin doesn't even have much sense for me.

Another solution, wider in scope but more applicable for general purposes, would be to add the the top level context menu "Coordinates" item which would have subitems:

- Go to User origin
- Go to Grid origin
(- Go to somewhere else useful?)
- Set Grid origin here
(- Set something else useful here?)

That would solve the problem as long as User origin can still be set to a wanted point graphically. Then I could go there with the menu item, open the context menu again (carefully without moving the mouse) and set the grid origin there.

(EDIT: actually just "Set grid origin here" would be enough as long as I can snap to some point and open the menu from there, my thinking was too complicated...)

eelik (eelik) on 2018-11-02
description: updated
Seth Hillbrand (sethh) wrote :

I am unable to recreate this bug. For me, the tool snaps to grid and points.

Can you post of video of your procedure?

eelik (eelik) wrote :

Strange. I reported from Windows, now I'm in Linux and it still behaves the same. Video attached.

In Windows it was the latest nightly build. In Linux:

Application: kicad
Version: (6.0.0-rc1-dev-1108-g8be3471ba-dirty), debug build
Libraries:
    wxWidgets 3.0.3
Platform: Linux 4.13.0-46-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    Compiler: GCC 7.2.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Wayne Stambaugh (stambaughw) wrote :

I confirmed this on windows. Neither the measure nor the grid origin tools snap to grid. Interesting, they do on version 5.0.1 so something has changed in the dev branch.

Changed in kicad:
status: New → Triaged
importance: Undecided → Low
milestone: none → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision f2ccad39b610f6f74e6c8972574e7b3222309db9
https://git.launchpad.net/kicad/patch/?id=f2ccad39b610f6f74e6c8972574e7b3222309db9

Changed in kicad:
status: Triaged → Fix Committed
assignee: nobody → Seth Hillbrand (sethh)
eelik (eelik) wrote :

OK, now the Grid origin tool snaps to grid. But not to the special points, and the Measure tool doesn't either.

The measure tool doesn't snap to magnetic pads, but it was in your TODO list: https://bugs.launchpad.net/kicad/+bug/1801377.
And so was snapping to special points: https://bugs.launchpad.net/kicad/+bug/1801369

Seth Hillbrand (sethh) wrote :

Yes. The remainder is a dupe of the previous bug report. I have a fix that I've been testing but want to make sure there's no unintended consequences first. I'll try to finish that testing tonight.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers