Backspace moves the textcursor back to start in pad properties, size X and Y

Bug #1800476 reported by Frank Severinsen on 2018-10-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

Steps to reproduce:
- open a footprint in the footprint editor
- hover over a pad, and press E to open the properties
- select the "Size X" Textbox (on the right side, so the textcursor will be at the end of the numbers)
- press backspace
- Text cursor now moves to the beginning of the textbox

Application: kicad
Version: 6.0.0-rc1-unknown-4b44cbe~84~ubuntu18.10.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) nghttp2/1.32.1 librtmp/2.3
Platform: Linux 4.18.0-10-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Wayne Stambaugh (stambaughw) wrote :

I've seen this as well but only on linux. It doesn't happen on windows.

Changed in kicad:
status: New → Triaged
importance: Undecided → Low
milestone: none → 5.1.0
eelik (eelik) wrote :

Also selecting some character(s) and typing to replace the selection move the cursor.

Where this happens seems to be random, although there must be some logic. In Pad Properties it happens in:

Size X
Size Y
Shape offset X
Shape offset Y
Trapezoid delta
Hole size X
Hole size Y

But not in:
Pad number
Position X
Position Y
Orientation
Pad to die length
Corner size
Corner radius

I'm on Linux right now but I saw something similar in Windows, too. I'll have to check that.

Application: kicad
Version: (6.0.0-rc1-dev-1063-g7b1049025-dirty), debug build
Libraries:
    wxWidgets 3.0.3
Platform: Linux 4.13.0-46-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    Compiler: GCC 7.2.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Jeff Young (jeyjey) wrote :

I'm about to commit a change which will likely fix this. (However, since I don't have linux I can't test that. Please re-open if it does not, in fact, fix it.)

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: Triaged → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision f660ec7cf8c739722841b560dc25a68d86bbbeab
https://git.launchpad.net/kicad/patch/?id=f660ec7cf8c739722841b560dc25a68d86bbbeab

Changed in kicad:
status: In Progress → Fix Committed
Frank Severinsen (shack) wrote :

Thanks for the potential fix, Ill report back tomorrow when a new nightly has been released.
The speed of you guys is actually making the nightly delay seem quite long

eelik (eelik) wrote :

The fix seems to work in Linux.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers