Text in symbols show as blue and hides behind filled rectangles

Bug #1800350 reported by Nick Østergaard on 2018-10-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Jeff Young

Bug Description

There are essentially two bugs here, but as I think they are closely related I will keep the bug description in one report.

Issue:
 1. Text in symbols are hidden behind filled rectangles in the symbol editor
 2. Text in symbols are colored text blue instead of the symbol dark red color

How to reproduce:
 1. Open the USB_C_Receptacle from 5.0.0 libraries in the symbol editor to reproduce issue 1.
 2. Add USB_C_Receptacle from 5.0.0 libraries in eeschema to reproduce issue 2.

See attached image for an illustration of the issue.

Application: kicad
Version: (6.0.0-rc1-dev-1045-g4b44cbe69), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.1 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.34.0
Platform: Linux 4.18.16-arch1-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.68.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.1
    Compiler: GCC 8.2.1 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=OFF
    KICAD_SCRIPTING_MODULES=OFF
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Nick Østergaard (nickoe) wrote :
description: updated
Jeff Young (jeyjey) on 2018-10-28
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: New → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision a8c7bb0c926ab6c77b1cee2fd7c031db1cae4cd2
https://git.launchpad.net/kicad/patch/?id=a8c7bb0c926ab6c77b1cee2fd7c031db1cae4cd2

Changed in kicad:
status: In Progress → Fix Committed
Nick Østergaard (nickoe) wrote :

Thank you Jeff, I can confirm that the fix works as expected :)

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers