Positioning of Schematic Graphic Text & Lines different from screen when plotted to PDF or SVG

Bug #1799605 reported by Mario DE WEERD on 2018-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Seth Hillbrand

Bug Description

I added some graphic lines to the schematic which look fine on screen but are misplaced in the PDF and the SVG output (from plot).

KiCAD version is 5.0.0 .

I try to add the images captures as attachments. You'll see that the text "Instrumentation Amplifier" is ok on screen, but in the SVG and PDF version the graphic line runs accros it.

SVG was read with Inkscape, PDF with Acrobat reader. These two tools work fine for other documents so I do not suspect that they would both have the same representation bug.

Mario DE WEERD (le-top) wrote :
Mario DE WEERD (le-top) wrote :
Mario DE WEERD (le-top) wrote :
Seth Hillbrand (sethh) wrote :

I cannot recreate this. Can you attach a sample schematic that shows this issue?

Mario DE WEERD (le-top) wrote :

Hi

Thank you for looking into this.

The GraphicLineBug.zip has a project demonstrating the issue. It also has the PDF and SVG files plotted from KiCAD.

Kind regards

Mario

tags: added: eeschema

This is issue may be related with the text render in the PDF, having different size between the Eeschema canvas and the output PDF.
I already have this problem your, but because this explanation.

Mario DE WEERD (le-top) wrote :

@Hildo: I do not believe this has to do with the PDF rendering.
1. I am using the Adobe Acrobat Reader DC, I think that it is the reference;
2. I get the same behavior with SVG in Inkscape, Google Chrome and Microsoft Edge.

Two different outputs (PDF and SVG), and different tools with the same rendering: 99.9% probability that it is the KiCAD generator.

Seth Hillbrand (sethh) on 2018-12-05
Changed in kicad:
importance: Undecided → Low
milestone: none → 5.1.0
status: New → Triaged
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 8d777dd5c3efb48901ed2fc47ce749063cfa7017
https://git.launchpad.net/kicad/patch/?id=8d777dd5c3efb48901ed2fc47ce749063cfa7017

Changed in kicad:
status: Triaged → Fix Committed
assignee: nobody → Seth Hillbrand (sethh)
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers