Symbol Editor paste doesn't show in current unit of multiunit symbol

Bug #1797183 reported by Seth Hillbrand on 2018-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Medium
Jeff Young

Bug Description

1) Create a multiunit symbol in Symbol Editor
2) Select a block of elements in Unit A that are not shared and "Copy Block"
3) Go to Unit B and press Ctrl-V to paste
4) Note that nothing displays in the window
5) Go back to Unit A without clicking or pressing escape and you see the block is currently available there for placing
6) Go back to Unit B and click on the screen. Note that the block is now visible in Unit B

Application: kicad
Version: (6.0.0-rc1-dev-858-g0090bea24), debug build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.52.1 OpenSSL/1.0.2l zlib/1.2.8 libidn2/0.16 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3
Platform: Linux 4.9.0-8-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    Curl: 7.52.1
    Compiler: GCC 6.3.0 with C++ ABI 1010

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=OFF
    KICAD_SCRIPTING_MODULES=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Jeff Young (jeyjey) on 2018-11-08
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 5.1.0
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 3de04e184b5b4e12767a3ed480d2145ef5f65b0f
https://git.launchpad.net/kicad/patch/?id=3de04e184b5b4e12767a3ed480d2145ef5f65b0f

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers