Update PCB from Schematic "show" checkboxes do not filter after running

Bug #1796992 reported by Seth Hillbrand on 2018-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Seth Hillbrand

Bug Description

Run "Update PCB from Schematic" on a new schematic or open and existing board and delete the components before running.

The log message window has a number of Info, Action, Error and Warning items. These should be hidden by unchecking the "Show" checkboxes below but they do not appear to be.

Application: kicad
Version: (6.0.0-rc1-dev-848-g13997f005), debug build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.52.1 OpenSSL/1.0.2l zlib/1.2.8 libidn2/0.16 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3
Platform: Linux 4.9.0-8-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    Curl: 7.52.1
    Compiler: GCC 6.3.0 with C++ ABI 1010

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=OFF
    KICAD_SCRIPTING_MODULES=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Jeff Young (jeyjey) wrote :

@Seth, this works for me on OSX. GTK-specific?

Jeff Young (jeyjey) wrote :

@Devs, can anyone else reproduce this?

Wayne Stambaugh (stambaughw) wrote :

The filtering works fine on windows so this could be gtk specific. There is a somewhat confusing behavior. If show all is checked, unchecking any of the filter options has no effect. Show all must be unchecked first. Is it possible that this is what the user is seeing? It might be worthwhile to uncheck show all when any of the filter options are checked and check all of the filter options when show all is checked. The current behavior is a bit confusing.

Changed in kicad:
status: New → Incomplete
Maciej Suminski (orsonmmz) wrote :

How about replacing "Show all" with a button? Or change the behavior, so that toggling the "Show all" checkbox affects the state of the remaining ones?

Wayne Stambaugh (stambaughw) wrote :

@Orson, A "Show All" button works as well.

Or just make them click 3 times (assuming you never turn them all off, as that’s kind of useless).

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 106eaaade6d1dd2036016146db1910b31c98e4dc
https://git.launchpad.net/kicad/patch/?id=106eaaade6d1dd2036016146db1910b31c98e4dc

Changed in kicad:
status: Incomplete → Fix Committed
assignee: nobody → Seth Hillbrand (sethh)
Seth Hillbrand (sethh) on 2018-11-24
Changed in kicad:
milestone: none → 5.1.0
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers