Changing Eeschema label type doesn't set the connected flag

Bug #1796775 reported by Seth Hillbrand on 2018-10-09
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Medium
Jeff Young

Bug Description

Place a global label on a wire. Note that it is correctly connected (No square). Change the type to hierarchical label. Note that the label now thinks it is disconnected (square shows). Press 'M' on the label, don't move it and click to place. Note that the label is again connected.

Desired behavior:
Changing the label type should not change the connected flag of the label.

Application: kicad
Version: (6.0.0-rc1-dev-729-g1b37f93cf), release build
Libraries:
    wxWidgets 3.0.2
Platform: Linux 4.9.0-8-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.8.0
    Compiler: GCC 6.3.0 with C++ ABI 1010

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jeff Young (jeyjey) on 2018-10-09
Changed in kicad:
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 5f0ffe84905ec53d02bfc38653baa31a510463e3
https://git.launchpad.net/kicad/patch/?id=5f0ffe84905ec53d02bfc38653baa31a510463e3

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers