PCBnew crashing - allocating video memory for cached container: out of memory

Bug #1795240 reported by Gadi Lahav on 2018-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Seth Hillbrand

Bug Description

Hello

When I first installed the stable KiCAD 5.0 (using the Ubuntu installation instructions) it worked fine and stable. For some reason when I try to use either PCBnew or the footprint editor, I immediately get the message

Error:allocating video memory for cached container: out of memory

I am using a PC with a (relatively) old AMD graphics card, running ubuntu 14.04.

Here is the version info

Application: kicad
Version: 5.0.0-fee4fd1~66~ubuntu14.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.35.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3
Platform: Linux 3.16.0-77-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.54.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.35.0
    Compiler: GCC 4.8.4 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Please advise how should I proceed

Gadi Lahav (glahav) wrote :
Seth Hillbrand (sethh) wrote :

Can you provide the output of the command

lspci -vvnn

Gadi Lahav (glahav) wrote :

Sure

Attacehd

Seth Hillbrand (sethh) wrote :

I've finally located a very old model intel and amd cards to see if I can track down some of these issues.

In the meantime, for this I think we'll just allow it to fall back semi-gracefully to Cairo.

Changed in kicad:
milestone: none → 5.1.0
assignee: nobody → Seth Hillbrand (sethh)
status: New → Triaged
importance: Undecided → High
Gadi Lahav (glahav) wrote :

I purged the software and most of it's pre-requisites, re-installed.
Now everything is working for some reason (I feel ashamed for trying this now).

If it will crash again in the same way, I'll re-open.

Cheers

Maciej Suminski (orsonmmz) wrote :

Gadi, I am glad that you have managed to resolve your problem. There is no reason to be ashamed.

Computers/video cards do not have infinite memory, so one can always find a design that is complex enough to require more memory than available on the system. Our role is to prevent crash in such case, so the bug stays valid.

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision fe30460aeb916483e9b1ce871031b43732c910cd
https://git.launchpad.net/kicad/patch/?id=fe30460aeb916483e9b1ce871031b43732c910cd

Changed in kicad:
status: Triaged → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers