ctrl-c not working

Bug #1794310 reported by Franck78 on 2018-09-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Hello

ctrl-c is not working as expected, eg do nothing 'visible'.

-select some items
-ctrl-c

a cursor change occurs. Until another click, pcbnew is somewhere....

Application: kicad
Version: 5.0.0, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.37.0 OpenSSL/1.0.2j zlib/1.2.8 libidn/1.28 libssh2/1.4.3
Platform: Linux 4.4.155-68-default x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,STL containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.61.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.37.0
    Compiler: GCC 4.8.5 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Tomasz Wlostowski (twlostow) wrote :

Which program? Eeschema, pcbnew?

Tom

Franck78 (fbourdonnec) wrote :

pcbnew

Wayne Stambaugh (stambaughw) wrote :

I'm assuming we are talking about the modern canvases here. If so, I believe this is the new behavior which is more in line with typical copy/cut/paste behavior. You now have to perform a paste operation to see the cut or copied objects. The new reference point selection is a nice feature. I know this differs from the legacy canvas where the copied object was attached to the cursor but this was always a bit odd compared to most apps.

Franck78 (fbourdonnec) wrote :

Ok, I don't really see the feature.

Can you make it so that ctrl-c is effectively copying the selection to the clipboard without having to 'end' the feature ?

"You now have to perform a paste operation to see the cut or..." yep but nothing is in the clipboard after ctrl-c

Wayne Stambaugh (stambaughw) wrote :

I see the issue now. I was using the dev branch for my testing which is significantly different than the 5.0 branch. The 5.0.0 and 5.0.1-defv behavior is awkward because there is no indication that you need to select a reference point after cut or copy command. Also, cut does not remove the selected objects until the paste command is issued so it is confusing. All of this has been fixed in the dev branch as one would expect. It probably should be back ported to 5.0.0 but I'm not sure how much effort this would be.

Franck78 (fbourdonnec) wrote :

"It probably should be back ported to 5.0.0 but I'm not sure how much effort this would be"

I would say release 5.1 now with all the fixes, set 5.2 for fosdem, and let's say 5.0.x was rc4 ;-)

Jeff Young (jeyjey) wrote :

That was fixed in https://git.launchpad.net/kicad/patch/?id=30bb9111540038c6f65dcd6ce52b9dc903c151d3.

Unfortunately it would not be terribly easy to back-port because the PickerTool was off in its own little world and had to be overhauled to fit with the other tools.

It could be done, though.

Jeff Young (jeyjey) wrote :

PS: I didn't worry too much about back-porting at the time as I assumed this bug also existed in 4.0.7. Does it not?

Franck78 (fbourdonnec) wrote :

I think ctrl-c is not used (in pcbnew).

Replaced by ctrl-d.

When I wanted to copy my final design to another board, it was a real ctrl-a ctrl-c, change of context, ctrl-v, but who does that ? Hence no bug report.

Franck78 (fbourdonnec) wrote :

and now I don't understand at all if this is fixed or not or duplicate of
lp:1786727 for v5.0
and it does not matter ;-)

Wayne Stambaugh (stambaughw) wrote :

@Jeff, I'm fine with the fix being release in 5.1. As far as 4.0 goes, I think the copy/cut/paste behavior completely changed during v5 development.

Seth Hillbrand (sethh) on 2018-10-23
Changed in kicad:
status: New → Fix Committed
milestone: none → 5.1.0
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers