align selected objects on grid

Bug #1793888 reported by Franck78 on 2018-09-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Medium
Seth Hillbrand

Bug Description

Hello,

start with empty pcb

for comprehension, set grid to 100mils
and select "mm" units

create a square for egdescuts, 100mm x 100mm ,top left at 0,0

select your square and move it somewhere in the center.
top left is on a grid point, ok, good

change grid to 2,5mm

select you square again, you cannot align it to the grid
-this is the bug

The story here is you don't really care of grid size at startup.
You are focused on drawing your edges (at least me) then moving that away from the red lines
(but you want to keep the red lines as ref)

-improvement one : make sure grid size follows the unit selected until the pcb have his first object, with a decent human 100mils or 2.50mm size

-improvement two, optional, use the very first mouse rectangle interaction to define a rectangular pcb edgescuts set. With sizes being shown in big font saying "creating initial pcb edges 9,8mm x 22mm"
It is so frustrating to have first mouse interaction doing nothing when obviously this can be done.

-improvement three : end the mouse operation with a contextual menu saying
--create edgescuts
--create edgescuts & planes zones, because zones are another painful things to create.

Application: kicad
Version: 5.0.0, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.37.0 OpenSSL/1.0.2j zlib/1.2.8 libidn/1.28 libssh2/1.4.3
Platform: Linux 4.4.155-68-default x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,STL containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.61.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.37.0
    Compiler: GCC 4.8.5 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Jeff Young (jeyjey) on 2018-09-24
Changed in kicad:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 5.1.0
Seth Hillbrand (sethh) on 2018-09-24
Changed in kicad:
status: Confirmed → In Progress
assignee: nobody → Seth Hillbrand (sethh)
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision edde02481e035843889d8a66f04c24ff8600d010
https://git.launchpad.net/kicad/patch/?id=edde02481e035843889d8a66f04c24ff8600d010

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers