feature to swap values for reference onto silk screen

Bug #1793429 reported by zakhar nasimov on 2018-09-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Wishlist
Unassigned

Bug Description

Currently if one prefers to have values on the silk per component instead of reference they must swap them one by one manually or modify the footprint.

This bug is a feature request to implement functionality to permit Eeschema to place values onto silk layer for PCBNew instead of reference being on silk layer if desired by the user.

summary: - feature to swap layer objects to other layers especially value to
- reference
+ feature to swap values for reference onto silk screen

This would be nice, specially for testpoints.

Also note that even if you move the value of a footprint to the Silks layer they are not included in
the corresponding gerber layer or 3d view.

Changed in kicad:
status: New → Triaged
importance: Undecided → Wishlist
Jeff Young (jeyjey) wrote :

This can be done in the Edit Text and Graphic Properties dialog in 5.1.

Changed in kicad:
status: Triaged → Fix Committed
milestone: none → 5.1.0

Wow, I didn't notice that dialog before.

The steps would be:
- for all footprints of interest:
    - Move value to the Silks layer and set text to visible
    - Set reference to invisible (this step doesn't work, leaving "Value" unchecked doesn't change visibility)
- Export gerbers selecting export footprint references and values

It's less work than manually swapping the layers for every footprint.

Example of doing the first step for all footprints "TestPoint:TestPoint_Pad_D2.0mm"

Jeff Young (jeyjey) wrote :

@Fabian, can you attach a screenshot of what doesn't work (ie: the second step)?

Thanks,
Jeff.

Sure

I also tried using no filter.

PD: a nice addition to the filter fields would be a negation.

Jeff Young (jeyjey) wrote :

Visible, Italic and Keep upright should be 3-state checkboxes. Are they in the indeterminate state? (I'm not sure what they look like on GTK, but I've attached an image of the 3 states on OSX.)

mm, that's the issue, when I open the dialog the checkbox is empty, clicking one more time it remains empty and clicking once more time it changes to checked.

Clicking the checkbox once makes the action function correctly.

I've changed theme and it is a issue with the theme I'm using (Numix), the default (Adwaita) shows the control correctly.

Jeff Young (jeyjey) wrote :

Cool; thanks for reporting back.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers