Update PCB from schematic or Read netlist doesn't add footprints

Bug #1793396 reported by Fabián Inostroza on 2018-09-19
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
jean-pierre charras

Bug Description

The 5.0 branch works fine.

Application: kicad
Version: (6.0.0-rc1-dev-541-gebb74fcc2), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 GnuTLS/3.5.19 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.32.0 librtmp/2.3
Platform: Linux 4.18.0-1-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Jeff Young (jeyjey) wrote :

This works for me (OSX). Can anyone else reproduce this?

I think you need to start a new project to reproduce the problem.
If I load the netlist using 5.0, save and reopen using the master branch then new footprints are added.

But if the board is empty and I load the netlist using the master branch then nothing is added.

I noticed that m_Modules is empty in pcbnew/class_board.cpp:2571 and the modules are added in that loop.

Test project

Paul Hansel (paulhansel) wrote :

Same issue on 6.0.0-rc1-dev-549-gd139a49. Accidentally posted a duplicate bug here: https://bugs.launchpad.net/kicad/+bug/1793624.

Attached is an example project that has the issue.

Martin Vítek (martin.vitek) wrote :

Same issue is on Fedora 28 build from Copr @kicad/kicad repository.

Affected builds:
    kicad.x86_64-100:r13783-618182dc.fc28
    kicad.x86_64-100:r13777-ebb74fcc.fc28

Previous working build:
    kicad.x86_64-100:r13755-2b634004.fc28

It happens only when a board has no footprint.

Changed in kicad:
status: New → Confirmed
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 0be52a68fe90dd876fd100197b1a96b97a27a37e
https://git.launchpad.net/kicad/patch/?id=0be52a68fe90dd876fd100197b1a96b97a27a37e

Changed in kicad:
status: Confirmed → Fix Committed
assignee: nobody → jean-pierre charras (jp-charras)
Changed in kicad:
milestone: none → 5.1.0
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers