Cant use Edge.Cut on footprint

Bug #1792742 reported by Leandro Heck on 2018-09-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Jeff Young

Bug Description

It is not possible to use Edge.Cut in Footprint by default.
But it is possible by importing a DXF to Edge.Cut layer.

So, editing the imported line, I get this warning:
"This item was on a forbidden or non-existing layer. It has been moved to the first allowed layer."

When I click Ok, the selection on the Layer dropdown list is EMPTY. So, it was not moved to the first allowed layer. Then, If I click OK (with empty layer) Kicad crashes.

Please, enable Edge.Cut on footprints. It is good to store borders outlines for reuse. SURE, it is possible to give the warning saying that it is not a valid layer for a regular part footprint.

*USING the latest nightly.

Application: kicad
Version: 6.0.0-rc1-unknown-243b05b~84~ubuntu18.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-25-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.58.0
    Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jeff Young (jeyjey) wrote :

The layer select box bug was fixed in Tom's branch (so it hasn't been merged yet).

(The rest of this is a duplicate of https://bugs.launchpad.net/kicad/+bug/1251393.)

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: New → In Progress
Jeff Young (jeyjey) on 2019-03-05
Changed in kicad:
status: In Progress → Fix Committed
Jeff Young (jeyjey) on 2019-03-05
Changed in kicad:
milestone: none → 5.1.0
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers