saving a footprint opened from a board has usability problems

Bug #1792256 reported by eelik on 2018-09-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Medium
Jeff Young

Bug Description

There are usability problems with the new Footprint Library Editor when a footprint is opened from a board to be edited. First, the editor seems to select the original library's footprint in the tree view. That's misleading because that's not the footprint which is under work. Then there's the save action which normally saves the opened footprint to the file which is selected in the tree view. But now it doesn't do that, it saves to the board from which the footprint was opened, which is inconsistent. And lastly it's not obvious that you can save the footprint to the board at all because there's no hint about that kind of action anywhere. The tool button which was still in v5.0 isn't there anymore, and even the tooltip of the Save button says it saves to the active library, which isn't true.

Jeff Young (jeyjey) on 2018-09-13
Changed in kicad:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 5.1.0
Jeff Young (jeyjey) on 2018-09-13
Changed in kicad:
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision e5e1a315f19a612bc0719a5c27f2750edcb68c43
https://git.launchpad.net/kicad/patch/?id=e5e1a315f19a612bc0719a5c27f2750edcb68c43

Changed in kicad:
status: In Progress → Fix Committed
eelik (eelik) wrote :

The first problem is now gone. But the two other remain. File->Save and the toolbar button save to the board but the button has wrong tooltip. And it's not obvious that there exists "Save to board" functionality.

Seth Hillbrand (sethh) wrote :

@eelik-

This is one reason to open a bug report for individual issues rather than grouping them. Please report specific issues in separate bug reports. If they have the same underlying issue, we can group them later.

Jeff Young (jeyjey) wrote :

I don't consider the others bugs.

The old tool button was part of the Active Library concept, which many found confusing (and was certainly non-standard). It was hard to figure out all the comings and goings.

In the new model you open something and then save it. If you open a footprint in the library, then saving it saves it to the library. If you open a footprint from the board, then saving it saves it to the board.

eelik (eelik) wrote :

Sorry for this issue cluster. This time I'll continue here and try to be more selective in the future.

I understand that another "save" item would be even more problematic. Reusing existing items is good, but now the tooltip of the Save button in the toolbar reads "Save footprint in existing library", which is wrong when the footprint is actually saved to the board. Could it be possible to change the texts according to situation, so that the File menu item and the tooltip would read "Save to board" when it would be saved to board? When someone who doesn't yet know tries to find "save to board" function somewhere it's probable that he reads either the tooltip or the File menu item. Originally the tooltip text fooled me to *not* to try it.

Jeff Young (jeyjey) wrote :

Oops, I did miss the tooltip. That needs to be fixed.

Changed in kicad:
status: Fix Committed → Triaged
Jeff Young (jeyjey) on 2018-09-13
Changed in kicad:
status: Triaged → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 4d6cd52ffcd6e528a0fef16a1db9eb61ed0dcb88
https://git.launchpad.net/kicad/patch/?id=4d6cd52ffcd6e528a0fef16a1db9eb61ed0dcb88

Changed in kicad:
status: In Progress → Fix Committed

What is the expected behaviour?
If I open a footprint currently placed in the board (Right click, open in footprint editor), edit and save, the library that footprint comes from is highlighted (I have to scroll in the tree so see it) and after saving, the changes are saved to the library, not the footprint in the board.

Application: kicad
Version: (6.0.0-rc1-dev-654-g89a3d2b45), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 GnuTLS/3.5.19 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.32.0 librtmp/2.3
Platform: Linux 4.18.0-1-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

eelik (eelik) wrote :

Did you ask a rhetorical question answering it yourself, or did you ask other people's opinion about the expected behavior and tell what actually happens for you?

@eelik, the second option

eelik (eelik) wrote :

I can confirm the problem. Something has changed since I tested Jeff's bugfixes.

Jeff Young (jeyjey) on 2018-10-01
Changed in kicad:
status: Fix Committed → Confirmed
Jeff Young (jeyjey) wrote :

Embarrassing. I broke it myself.

Link should be cleared only when adding a footprint from a library.

Changed in kicad:
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision dfe164e0dc6ba37cfbe66df52fb84ff245dcf153
https://git.launchpad.net/kicad/patch/?id=dfe164e0dc6ba37cfbe66df52fb84ff245dcf153

Changed in kicad:
status: In Progress → Fix Committed
eelik (eelik) wrote :

Seems to be okay now.

Franck78 (fbourdonnec) wrote :

What is the expected behaviour?
If ...the changes are saved **to the library**, not the footprint in the board.

This is just an heresy. The global SYMBOLS/FOOTPRINTS must be seeing as shared/read only/stable resource.
Not something you can screw whenever you want.

The correct way to do it, is work on your local project's copy of the lib then publish it to the global repo when you are done.

How do you just save a project if you start editing shared resources everywhere ?? Nonsense.

The correct behavior is allways have Kicad creates a private lib/private footprint and save in them only. Never directly (and that as nothing to do with privileges).

@Frank78, I also would like something like that, copy and reference everything to a local copy of schematic/footprint/3d libraries and have truly "portable" projects. But for now is fine.

Thanks Jeff.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers