pcbnew: microwave line tool creates non-smooth lines

Bug #1792119 reported by Eugeniy Meshcheryakov on 2018-09-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Low
John Beard

Bug Description

I'm trying to use the line tool from the microwave tool bar. It seems to work fine when one specifies length that is much larger than the distance between ends. The line looks broken when one accepts default length or specifies one that is only slightly larger than the distance between end points. See the attached screenshot.

Kicad version (from Debian unstable):

Application: kicad
Version: 5.0.0+dfsg1-2, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.33.0 librtmp/2.3
Platform: Linux 4.18.0-1-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

This bug is also reproducible with current git master:

Application: kicad
Version: (6.0.0-rc1-dev-480-gf5de8cd3e), release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.61.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.33.0 librtmp/2.3
Platform: Linux 4.18.0-1-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.61.0
    Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
    USE_WX_GRAPHICS_CONTEXT=ON
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Jeff Young (jeyjey) wrote :

@Eugeniy, does the current master still reproduce the problem when built with GTK2?

Seth Hillbrand (sethh) wrote :

I can confirm this one. The inductor tool is not fully parameterized.

I feel like the microwave toolset really belongs in the footprint editor but that's a bigger hurdle. For this bug, having the inductor set a minimum value at which the calculation is valid will be sufficient.

Changed in kicad:
importance: Undecided → Low
milestone: none → 5.0.2
status: New → Triaged
John Beard (john-j-beard) wrote :

This has always been the case (since at least pre-4, and probably since ever) with this tool when the length is under a certain limit.

Seth Hillbrand (sethh) on 2018-10-23
Changed in kicad:
milestone: 5.0.2 → 5.1.0
Changed in kicad:
assignee: nobody → John Beard (john-j-beard)
status: Triaged → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision d39cdb5565b3780d603924ca902fed72cc936480
https://git.launchpad.net/kicad/patch/?id=d39cdb5565b3780d603924ca902fed72cc936480

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments