Weird text rendering (Open GL mode)

Bug #1790016 reported by Oliver on 2018-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Medium
Seth Hillbrand

Bug Description

There seems to be a layering issue with OpenGL rendering where text of a 'background' object is drawn on top of other objects. Each glyph then has a block behind it which deletes the view of whatever it is on top of.

Best described in pictures (attached). It seems to only happen when items are selected and brought into focus "above" items which are normally displayed on top.

Application: kicad
Version: (6.0.0-rc1-dev-402-g020d837de), release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Oliver (schrodingersgat) wrote :
Oliver (schrodingersgat) wrote :
Oliver (schrodingersgat) wrote :
Seth Hillbrand (sethh) wrote :

Oh, that looks like a consequence of my layer order business.

Changed in kicad:
assignee: nobody → Seth Hillbrand (sethh)
importance: Undecided → Medium
milestone: none → 5.1.0
status: New → Confirmed
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision d6b95236a430acf7031b0a71d5cc211f73e7a51e
https://git.launchpad.net/kicad/patch/?id=d6b95236a430acf7031b0a71d5cc211f73e7a51e

Changed in kicad:
status: Confirmed → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers