Impossible to change properties of track/via selection with different via sizes

Bug #1789349 reported by Oleg Endo on 2018-08-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Medium
Jeff Young

Bug Description

Trying to modify properties of a tracks/vias selection (selected with U in pcbnew), where the selection consists of vias of different sizes, will always display the error message

Via drill size must be smaller than via diameter.

This makes it impossible to e.g. set the lock property of the selection. That used to work before until just recently.

Application: kicad
Version: 6.0.0-rc1-unknown-7c11d03~66~ubuntu18.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-33-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.58.0
    Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jeff Young (jeyjey) wrote :

While I can't reproduce this on OSX, I'm pretty sure I know what's happening and have a fix for it.

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
importance: Undecided → Medium
milestone: none → 5.1.0
status: New → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 4174ecf4c3ff004f2dc1ef3acc0e3146bbece48e
https://git.launchpad.net/kicad/patch/?id=4174ecf4c3ff004f2dc1ef3acc0e3146bbece48e

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers