DRC error on disabled layer

Bug #1788248 reported by Corné Voogt on 2018-08-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Medium
Maciej Suminski

Bug Description

I have footprints that contain silkscreen layer. When I disable the silkscreen layer in my design, than I get on every line/reference error 49. Example:

ErrType(49): Item on a disabled layer
    @ (120.630 mm,80.200 mm): “Graphic (Line) on F.SilkS of C202” is on a disabled layer

When a layer is disable, it should not be checked by the DRC.

Attached I added my design and when you run the DRC you get 601 errors. When the F.Silks is enable, then there are no error.

Gr. Corné Voogt

Corné Voogt (corne.voogt) wrote :
Jeff Young (jeyjey) wrote :

@Corné, are you aware that you can hide/show layers (using the layer manager to the right of the screen)?

Disabling a layer says it's no longer part of your board. Layers aren't meant to be disabled/reenabled as a common course of action.

Corné Voogt (corne.voogt) wrote :

I know about hide/show. In my design I do not want a silk on the top, so I disable it. To solve this problem I see 2 options:
1) Remove the possibility to disable it, or
2) Do not check disabled layers.

It took me a few hours to find out what the problem was and how to work around.

Jeff Young (jeyjey) wrote :

@Orson, this is due to the fix for https://bugs.launchpad.net/kicad/+bug/1779281. Any objections to me making that only check copper layers?

Alternatively, we could strip layers from footprints that are disabled when the footprint is added to the board. That would seem to be more inline with how reducing enabled layers works...

Seth Hillbrand (sethh) wrote :

You may or may not get a response this week (I think he's on vacation at the moment)

Jeff Young (jeyjey) wrote :

@Orson, ping.

Stripping disabled layers from footprints is breaking footprints.
Therefore if for some reason a disabled layer is re-enabled, you will get incorrect footprints.
I don't think layers used in footprints must be exactly the same as the board editor.
Footprints are also living in libraries.

Jeff Young (jeyjey) wrote :

@Orson, did you have a chance to look at my comment #4 yet?

Jeff Young (jeyjey) on 2018-09-12
Changed in kicad:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 5.1.0
Maciej Suminski (orsonmmz) wrote :

Jeff,

Apologies for late answer, your message must have been wearing camouflage when it arrived. I think that limiting the test to copper layers sounds like a better solution, and I do not mind changing the logic.

Jeff Young (jeyjey) wrote :

Cool, I'll leave it with you.

Changed in kicad:
assignee: nobody → Maciej Suminski (orsonmmz)
Changed in kicad:
status: Confirmed → Won't Fix
status: Won't Fix → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 4ad37bc9ea7f74cb970c43322a6d70805a5a6ee9
https://git.launchpad.net/kicad/patch/?id=4ad37bc9ea7f74cb970c43322a6d70805a5a6ee9

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers