3D models file list scroll bar

Bug #1787269 reported by Hildo Guillardi Júnior on 2018-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Jeff Young

Bug Description

When added more 3D models file that the window dialog allow to ft at the monitor, this list should use a scroll bar.
Check in the screensaved that I am not able to modify the coordinates.

Jeff Young (jeyjey) wrote :

Does this reproduce for anyone else on GTK? (It's fine on OSX.)

For clarify, it's (of course) depends of the monitor resolution and my version:

Application: kicad
Version: 6.0.0-rc1-unknown-3eb3db0~66~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.15.0-32-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jeff Young (jeyjey) wrote :

@Hildo, it shouldn't have anything to do with your monitor size. It would appear from your screen-shot that the dialog is growing with each additional 3D model. That shouldn't happen; it should just fill up the room available in the list and then start scrolling. The list should only grow if you drag the dialog larger (in which case the bottom half with the preview should grow slightly faster than the list).

Changed in kicad:
milestone: none → 5.1.0

After you, @jeff, shows the normal behavior, yes, it is not display dependent. I just realize on the "small" resolution display because, in the bigger one, the dialog keep expanding and but still fitting on display.

Yes, the no-scroll behavior happens on my Ubuntu (KiCad using Gtk2 as in version description) independent of the display resolution.

I could update the KiCad Nightly changing the Ubuntu PPA, but I still having problem to get the newest version (today 16-08-2018 I just got

kicad-nightly is already the newest version (201808100649+78ab5c3~84~ubuntu16.04.1)

But, return to the issue, in the "1 day more new release" (the PPA just give me a 1 date more new from the last one, but still 6 days out of date), the scroll bar are present, it just have some delay/freeze to respond to the mouse scroll wheel.

Jeff Young (jeyjey) wrote :

@Hildo, is the delay just the first time you scroll, or every time?

Every time (build 20180810, the last that I got), holding the left click and moving the scrooll appear normal.
I think will be better I get the last commit to comment in this report seen that just one day (on legacy PPA was 20180809) give me the scroll bar that wasn't present.

Today finally was released a new Nightly for Ubuntu (20180818), I hope that the problem with compilation was fix.
@jey, in this release the dialog box / scroll bar works normally, so I am marking this issue as concluded.

Changed in kicad:
status: New → Fix Released

I am changing again because found a new behavior:
Every think is fine if I don't try to re-size the dialog box, even if I resize in the vertical direction is fine.
But if I re-size it in the horizontal or in the diagonal direction the fist issue is reproduced.

Changed in kicad:
status: Fix Released → In Progress

Application: kicad
Version: 6.0.0-rc1-unknown-46fddab~66~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.15.0-32-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jeff Young (jeyjey) wrote :

Cool. That reproduces for me on Mac, so I should be able to track it down.

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision b4bb36f0172f229a807eb4ffda956c4b5b33f23b
https://git.launchpad.net/kicad/patch/?id=b4bb36f0172f229a807eb4ffda956c4b5b33f23b

Changed in kicad:
status: In Progress → Fix Committed

Working!

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers