Saving schematic fails intermittently

Bug #1786512 reported by Hildo Guillardi Júnior
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Fix Released
High
Unassigned

Bug Description

Using the last Night, after some change on the schematic the Eeschema (added some component) doesn't allow me to save and crash.
A friend mine (not PC expert, because this I don't have his report) told that is happing also in Pcbnew since 20180807 (Ubuntu also).
Because I don't have sure, yet, how to reproduce, and it's a critical bug, I am attacking the screen with the sequential dialog box that Eeschema give to me.

My version:
Application: kicad
Version: 6.0.0-rc1-unknown-3eb3db0~66~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-131-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :
Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :
Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :
Revision history for this message
Jeff Young (jeyjey) wrote :

Does the path in the 3rd dialog look correct? (In other words, does the directory it's trying to write to exist?)

If it looks OK, can you post the schematic here?

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Yes, the folder exist (I wasn't "saving as..." just "saving"). But the error appear to be intermittent.

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

In the images, hhe file manager have the folder opened on the display right and no other program (could synchronization or any kind) was accessing this folder at the bug moment, just the file manager and the Eeschema.

Revision history for this message
Jeff Young (jeyjey) wrote :

I can't reproduce this on OSX (with Hildo's files).

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Even in the Ubuntu machines that we (people from the same lab mine of the university) the error is *intermittent*. We have to keep modifying the PCB and same times the save result in this error.
One machine was Ubuntu 16.04 with Unity desktop other Ubuntu 16.04 with Gnome desktop.

We didn't try in others OS or Linux versions.

Is there some procedure that I can make to create a log file last time that this raise? (And so help you developers).

Jeff Young (jeyjey)
summary: - Can save file Eeschema
+ Saving schematic fails intermittently
Revision history for this message
Jeff Young (jeyjey) wrote :

I'm going to merge some code with more/better error messages in it. Stay tuned....

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Just to keep tracking, still on 201808091507+3eb3db0~66~ubuntu16.04.1

I am adding some more screens (not matter if Eeschema is opened alone or in the KiCad app).

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :
Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :
Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

The first error happens I don't know why.
The second and thirty appear be caused by the deletion of the project file (glade about the *.bak backups) in the first error.

I just have Ubuntu machines here and is happen in all them.

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Also happen on Pcbnew (not just on Eeschema, one frind mine report me this and I am confirm for him).
When the Pcbnew generate this error is necessary close all the KiCad app, because this just rename the backup to *.kicad_pcb, when clicked to open, KiCad warning me that is not possible to load the lib-table and load a "empty PCB".
Closing the Pcbne + Eeschema + Kicad of the related project, it make possible to rescue the last backup.

Revision history for this message
Jeff Young (jeyjey) wrote :

@Hildo, judging from those error messages I think you have the last build before my new error reporting stuff. Fetch a new build and try it one more time; hopefully it will give us better info....

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Yes, I usually (normally always) keep the Nightly up-to-date, to help with reports here, to put opinion on new features, and keep my Python script up-to-date too.
But, I don't known if there isn't any new Nightly build on PPA or Ubuntu compilation are having problems again (I reported this some weeks ago) but
https://launchpad.net/~js-reynaud/+archive/ubuntu/ppa-kicad/+packages
there isn't any new build on ppa (I am not with so much time to compile by my own).

Last time with this error was a not successful compilation on the `+packages`, now neither an error listed.

Checking on
http://downloads.kicad-pcb.org/windows/nightly/
there are new Windows.

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Related report about the Ubuntu packages:
https://answers.launchpad.net/kicad/+question/671336

Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

I create a report about the Ubuntu PPAs, since this still not get the last commit for me
https://bugs.launchpad.net/kicad/+bug/1787380

Even, @jeyjey I can't return you a debug because the last version
- in Legacy Nightly PPA is 20180809
- in Dev Nightly PPA is 20180810

And you better code warning / messages were just committed on 13-08-2018.

Revision history for this message
Jeff Young (jeyjey) wrote :

Setting importance to High at least until we figure out what's going on...

Changed in kicad:
importance: Undecided → High
Jeff Young (jeyjey)
Changed in kicad:
status: New → Incomplete
Revision history for this message
Hildo Guillardi Júnior (hildogjr) wrote :

Since version 201808200851+00d912f~66~ubuntu16.04.1
this issue didn't happen again.

I will re-open in case of return.

Changed in kicad:
status: Incomplete → Fix Released
Revision history for this message
Jeff Young (jeyjey) wrote :

Thanks, Hildo!

Changed in kicad:
status: Fix Released → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers