Add shortcut to "leave sheet"

Bug #1786113 reported by Leandro Heck on 2018-08-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Please add a default shortcut to go to the main sheet. Or using the kicad name to "leave sheet".

Also, a shortcut to go to the next/previous sheets would be good. Something with Page Down/Up. would be nice.

Leandro Heck (leoheck) wrote :

Using Kicad nightly and 5. :)

Wayne Stambaugh (stambaughw) wrote :

The default shortcut to leave the current sheet is Alt+Backspace.

Is it possible to add it near the Leave Sheet entry in View menu?

--
Leandro Heck

On Wed, Aug 8, 2018 at 6:10 PM Wayne Stambaugh <email address hidden>
wrote:

> The default shortcut to leave the current sheet is Alt+Backspace.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1786113
>
> Title:
> Add shortcut to "leave sheet"
>
> Status in KiCad:
> New
>
> Bug description:
> Please add a default shortcut to go to the main sheet. Or using the
> kicad name to "leave sheet".
>
> Also, a shortcut to go to the next/previous sheets would be good.
> Something with Page Down/Up. would be nice.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1786113/+subscriptions
>

And in the context menu with the mouse right click (a lot of existent shortcuts is missing there).

Wayne Stambaugh (stambaughw) wrote :

What are you asking to add here? There is already a "Leave Sheet" entry
in the "View" menu and in the context menu when you right click any
place in the schematic where there are no objects.

On 8/8/2018 5:19 PM, Leandro Heck wrote:
> Is it possible to add it near the Leave Sheet entry in View menu?
>
> --
> Leandro Heck
>
>
> On Wed, Aug 8, 2018 at 6:10 PM Wayne Stambaugh <email address hidden>
> wrote:
>
>> The default shortcut to leave the current sheet is Alt+Backspace.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1786113
>>
>> Title:
>> Add shortcut to "leave sheet"
>>
>> Status in KiCad:
>> New
>>
>> Bug description:
>> Please add a default shortcut to go to the main sheet. Or using the
>> kicad name to "leave sheet".
>>
>> Also, a shortcut to go to the next/previous sheets would be good.
>> Something with Page Down/Up. would be nice.
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/kicad/+bug/1786113/+subscriptions
>>
>

Leandro Heck (leoheck) wrote :

I was asking the feature to "Leave the sheet" with a keyboard shortcut. But you told me that this is an existing thing. I couldn't know just looking at the menus.

-> So, what is missing is the shortcuts indication on menu entries to indicate that the shortcut exists.

That was also the thing Hildo was pointing in his last comment.

If you go to the "Eeschema > View", you will see the "Leave sheet" item but there are no shortcuts indicated there.

For example "Eeschema > View > Zoom in" has this "Alt+F1" shortcut written there.

Also, just to improve here, I have another bug report that shows that some shortcuts indicated in the menus that are wrong, at least on Ubuntu. For example, all of the shortcuts in Place menu have the "Shift+" in front of it. This is wrong for most of the actions there.

Nick Østergaard (nickoe) wrote :

What platform are you on? I see it in nightly. I see it both in the view menu, the context menu and the hotkey list.

Application: eeschema
Version: (6.0.0-rc1-dev-238-gce3760438), release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Changed in kicad:
status: New → Incomplete
tags: added: eeschema
Leandro Heck (leoheck) wrote :

Nick, it is ok on nightly. My issue is on v5 (ubuntu).

Application: kicad
Version: 5.0.0-fee4fd1~66~ubuntu18.04.1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.58.0 OpenSSL/1.1.0g zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-30-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.65.1
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.58.0
    Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Nick Østergaard (nickoe) wrote :

You said in comment #1 that it does not work on nightly.

Leandro Heck (leoheck) wrote :

Yes, you are right. But I just tested both versions 3h ago and it is fixed in Nightly. Since I added the issue a week ago it may be fixed by someone or I could be my mistake when I reported it. So, right not, only v5 has the issue.

Nick Østergaard (nickoe) wrote :

This is why it is important to be exact when reporting version info when reporting bugs from the beginning..

Changed in kicad:
milestone: none → 5.1.0
status: Incomplete → New
Nick Østergaard (nickoe) wrote :

I targeted the 5.1.0 milestone as it is not a bug critical for 5.0 and it might appear in 5.1 depending on the exact branch strategy used.

Leandro Heck (leoheck) wrote :

Sure, that is ok. There are any ppa with version 5.1?

On Tue, Aug 14, 2018, 18:41 Nick Østergaard <email address hidden>
wrote:

> I targeted the 5.1.0 milestone as it is not a bug critical for 5.0 and
> it might appear in 5.1 depending on the exact branch strategy used.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1786113
>
> Title:
> Add shortcut to "leave sheet"
>
> Status in KiCad:
> New
>
> Bug description:
> Please add a default shortcut to go to the main sheet. Or using the
> kicad name to "leave sheet".
>
> Also, a shortcut to go to the next/previous sheets would be good.
> Something with Page Down/Up. would be nice.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1786113/+subscriptions
>
--
~ Leandro

Wayne Stambaugh (stambaughw) wrote :

I thought JP fixed this. I just tested this on linux and I still don't see Alt+Bkspc as the shortcut in either the menu or the context menu. Am I missing something?

Yes I fixed it.
Both on Ubuntu/KDE and Ubuntu/Unity I have Alt+Bksp displayed (with Bksp translated into "retour arrière" ...)

Jeff Young (jeyjey) wrote :

On OSX I see the shortcut in both menus.

@Wayne, are you still not seeing them on Linux?

Wayne Stambaugh (stambaughw) wrote :

@Jeff, I'm seeing the shortcut in both menus in heads of both the
development and 5.0 branches so it appears to be fixed.

On 09/12/2018 05:01 PM, Jeff Young wrote:
> On OSX I see the shortcut in both menus.
>
> @Wayne, are you still not seeing them on Linux?
>

Jeff Young (jeyjey) on 2018-09-12
Changed in kicad:
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers