Footprint editor crash when paste (SIGSEGV, Segmentation fault)

Bug #1785716 reported by Hildo Guillardi Júnior on 2018-08-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Critical
Unassigned

Bug Description

Footprint editor crash when I try to past after copy some selected part that I draw (silk or other pad).

I try to update this Nightly version from ppa to check if the error still on newer, but the Ubuntu Xenial compilation are failing since day 27/June/2018.

Application: pcbnew
Version: 6.0.0-rc1-unknown-0cca1c6~65~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-131-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Some degub:

gdb pcbnew
GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.5) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from pcbnew...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/pcbnew
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffeb5ac700 (LWP 28584)]
[New Thread 0x7fffeadab700 (LWP 28585)]
[New Thread 0x7fffea5aa700 (LWP 28586)]
[New Thread 0x7fffd153a700 (LWP 28603)]
[New Thread 0x7fffc9e64700 (LWP 28604)]
[New Thread 0x7fffc9663700 (LWP 28605)]
[New Thread 0x7fffc8e62700 (LWP 28606)]
[New Thread 0x7fffc7d81700 (LWP 28607)]
[New Thread 0x7fffc7580700 (LWP 28608)]
[Thread 0x7fffc7d81700 (LWP 28607) exited]

Thread 1 "pcbnew" received signal SIGSEGV, Segmentation fault.
0x00007fffdb53a2e4 in ?? () from /usr/bin/_pcbnew.kiface

summary: - Footprint editor crash when past
+ Footprint editor crash when past (SIGSEGV, Segmentation fault)

I cannot reproduce this bug on windows. Please list the exact steps you take to create the bug. Please include which canvas you are using (Legacy, Modern Accelerated, or Modern Fallback). Does this occur with any footprint or a specific footprint? If it's a specific footprint, please include a copy of the footprint with the bug report.

Changed in kicad:
status: New → Incomplete

Step:
1) Open Pcbnew;
2) Open the footprint editor;
3) Open any footprint (here I reproduce even with the build in library);
4) Select and copy some silk;
5) Try to past, can have 2 think:
5a) Nothing, really nothing doesn't past and you try again. So really happens (5b).
5b) Crash and segment fault.

In both: Accelerated and Fallback. In legacy I wasn't able to copy anything on Footprint editor, maybe this option is not available.

Changed in kicad:
importance: Undecided → Critical
Jeff Young (jeyjey) wrote :

It won't reproduce with edges. Has to be a module text item.

summary: - Footprint editor crash when past (SIGSEGV, Segmentation fault)
+ Footprint editor crash when paste (SIGSEGV, Segmentation fault)
Changed in kicad:
status: Incomplete → Confirmed
assignee: nobody → Jeff Young (jeyjey)
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 84504599ce29d6d1f0800702c1cbb1481efce326
https://git.launchpad.net/kicad/patch/?id=84504599ce29d6d1f0800702c1cbb1481efce326

Changed in kicad:
status: In Progress → Fix Committed

Sorry Jeff, but it is not fixed: it crashes on my install (W7/32bits).

Because you are saying:
"Has to be a module text item"
I am guessing the crash is mainly due to the fact mandatory fields are copied, which is not allowed, or not mandatory fields are copied with the same field name, which ids certainly not a good idea.

Changed in kicad:
status: Fix Committed → New

Also now in just compiled few minutes ago 201808071515+539ca5a~66~ubuntu16.04.1, this crash still.

Jeff Young (jeyjey) wrote :

@JP, we do appear to convert them to TEXT_DIVERS. The bug I fixed was that they didn't have a viewPrivData defined yet, and we crashed trying to see if the new item was visible (which isn't necessary in ModEdit anyway because we make everything visible).

Sounds like there might be an additional bug (or my fix wasn't sufficient).

Changed in kicad:
assignee: Jeff Young (jeyjey) → nobody

Not present in version 20180809.
The @kicad-janitor wasn't present on Ubuntu due a compilation farm problem already fixed.

Changed in kicad:
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers