export footprint always disabled

Bug #1785226 reported by m on 2018-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Jeff Young

Bug Description

Hi,
after the recent commits, Export Footprint in Footprint Editor "File" "Export Footprint" is always disabled... There is no way to export to a file a modified footprint.

m (easyw) wrote :
description: updated
summary: - export footprint
+ export footprint always disabled
m (easyw) on 2018-08-03
tags: added: footprinteditor
removed: footprint
tags: added: editor footprint
removed: footprinteditor
Jeff Young (jeyjey) wrote :

It's possible that I fixed this, or it's possible that I just can't reproduce it.

You should have the item enabled when either (a) a footprint is selected in the Libraries tree in the left-hand side of the window, or (b) when there is a footprint being edited on the canvas. If that's not the case for you, can you post a screen shot of more of the screen so I can attempt to figure out what's going on? Thanks!

Changed in kicad:
status: New → Fix Committed
m (easyw) wrote :

Hi @jeyjey
sorry for the late reply but I was on holidays...
here my full update:
1) I'm using the latest k6 dev build for win64 (full details below)
2) Launching the fp editor I can Import an existing footprint.
3) After having changed something I just miss completely the option to export the footprint... the menu just keeps greyed and it is impossible to export the fp.
4) I'm attaching a screenshot.

Application: pcbnew
Version: (6.0.0-rc1-dev-382-gcc26da394), release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Jeff Young (jeyjey) wrote :

Ahh... it's the Import that's key. I can now reproduce it. (It's because the imported footprint has no library ID yet so the code erroneously thinks it's invalid.)

Changed in kicad:
status: Fix Committed → Confirmed
importance: Undecided → High
milestone: none → 5.0.1
Jeff Young (jeyjey) wrote :

(As a temporary work-around you can use Save As... to save it to an existing library and then Export it.)

Jeff Young (jeyjey) on 2018-08-27
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
milestone: 5.0.1 → 5.1.0
m (easyw) wrote :

Hi,
I modified two files:
1) footprint_edit_frame.cpp
 // UI update events.
 // EVT_UPDATE_UI( ID_MODEDIT_EXPORT_PART, FOOTPRINT_EDIT_FRAME::OnUpdateModuleTargeted ) /*here*/
 EVT_UPDATE_UI( ID_MODEDIT_EXPORT_PART, FOOTPRINT_EDIT_FRAME::OnUpdateModuleSelected )
2) footprint_editor_utils.cpp
 case ID_MODEDIT_EXPORT_PART:
   // Export_Module( LoadFootprint( getTargetLibId() ) ); /*here*/
   // break;
   if( GetBoard()->m_Modules )
       Export_Module( GetBoard()->m_Modules );
   break;

This is fixing the exporter as it behave before

KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 2e8f2d28503a5566a4e2cf275ac2a68f7cc1ce46
https://git.launchpad.net/kicad/patch/?id=2e8f2d28503a5566a4e2cf275ac2a68f7cc1ce46

Changed in kicad:
status: Confirmed → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers