Annotate Schematics can't clear current assignment

Bug #1782999 reported by Christian Geilgens on 2018-07-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Critical
Maciej Suminski

Bug Description

Using Version 6.0.0-rc1-dev-107-gb6934bf54

In the Schematics i perform the clear Annotation and the programm is hanging. The dialog with the buttons "hell" ?? and "Cancel" can't get removed anymore.
The same happens, if i use the option "Reset existing annotations".
Option "Keep existing annotations" is working fine.
Previous rc ( 5.1) was working without any problems

Jeff Young (jeyjey) wrote :

Is it the attached dialog that can't be closed?

This is correct. the first button have the caption "Clear" or Clear and "Annotate", depending of the options

I remember once i saw the word "hell" but i am not able to iterate this again.

Jeff Young (jeyjey) wrote :

I'm not able to reproduce this. Can you attach your schematic?

Jeff Young (jeyjey) wrote :

Well, rats. Doesn't reproduce for me, even with your schematic.

What platform are you on? (Better yet, open the About Kicad dialog and click the Copy Version Info button and paste the result here.)

strange, but its definitely happens here. Seems that i need to built it here and trace the code....

Application: kicad
Version: (6.0.0-rc1-dev-107-gb6934bf54), release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011
Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Alex Paris (alparis) wrote :

Hi, Same problem for me too. Clicking on the "Clear Annotation" button shows confirmation message with "Clear" and "Cancel" buttons, but clicking on any button has no any reaction, even closing this message window has no reaction too. Application is hanging. Tried kicad-r10730.7f64f4124-x86_64.exe 22-Jul-2018 and kicad-r10699.93c173fcd-x86_64.exe 18-Jul-2018 nightly builds, both of these has this bug.

So then its a problem that caused by the windows versions and its happens in the recent versions only

Jeff Young (jeyjey) wrote :

It's MSW-specific and related to the dialog used (one with a "Don't show again" checkbox). I think Wayne and Orson are looking into it....

@Orson, are you going to take a look at this?

On 7/23/2018 12:24 PM, Jeff Young wrote:
> It's MSW-specific and related to the dialog used (one with a "Don't show
> again" checkbox). I think Wayne and Orson are looking into it....
>

Maciej Suminski (orsonmmz) wrote :

Yes, I will check it. I think the 'hell' button label mentioned in #1 is a clear indicator that your PC has been possessed by demons. I recommend sprinkling some holy water on the keyboard before we continue with fixes.

Changed in kicad:
assignee: nobody → Maciej Suminski (orsonmmz)
Seth Hillbrand (sethh) wrote :

@christian68 Are you running a german environment for KiCad?

Yes i am in a germany environment

Changed in kicad:
status: New → In Progress
importance: Undecided → Critical
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 39d8d143d6d30dd0e5ffc717ee6fe00c92b1d15d
https://git.launchpad.net/kicad/patch/?id=39d8d143d6d30dd0e5ffc717ee6fe00c92b1d15d

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers