pcbnew: Differential Pair Custom Values Not Working

Bug #1782971 reported by Alex on 2018-07-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Jeff Young

Bug Description

I am having a lot of difficulty in trying to route a controlled impedance differential pair. I am trying to make a pair with 14thou wide traces with 20thou spacing, but unfortunately every time I chose to select the custom value and start to route a differential pair, it defaults straight to a pair of 0.2mm wide traces and a spacing of 0.25mm.

I cannot find out how to route the differential pair that I require for my design as it is being reset every time I try to do so.

I was earlier having a different issue regarding differential pairs, so I decided to try out a the latest nightly build, however I am now faced with this issue. Can anyone recommend me a nightly build which is known to work well with differential pairs?

Application: kicad
Version: (6.0.0-rc1-dev-107-gb6934bf54), release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

tags: added: pcbnew pns
Changed in kicad:
milestone: none → 5.1.0
Jeff Young (jeyjey) wrote :

@Alex, the pre-defined values appear to be working in that build. Go to File > Board Setup > Tracks & Vias and enter your dimensions into one of the Differential Pairs lines. You'll then see it on the router right-mouse-button menu (below Use Custom Values... in the Select Differential Pair Dimensions menu). Select it there and you should be good.

Changed in kicad:
status: New → Confirmed
Jeff Young (jeyjey) on 2018-07-22
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 53f35a3f54f9b671fdc90382c57c21280b5a81db
https://git.launchpad.net/kicad/patch/?id=53f35a3f54f9b671fdc90382c57c21280b5a81db

Changed in kicad:
status: In Progress → Fix Committed
Jeff Young (jeyjey) wrote :

@Alex, alternatively you can wait for the next nightly to be built and it should be fixed there.

Alex (knapik1227) wrote :

Ah, thank you very much about the tip about the pre-defined values. Sorry, I just got a bit frustrated due to it being a student project which I'm being pushed for time, and I upgraded from another nightly build which had an issue only to face another I couldn't understand how to get around. I'll try out the next nightly build in the coming few days, and I'll report if I find any more issues. Once again, thank you very much.

Alex (knapik1227) wrote :

I can confirm that its working now, thank you! I've also made a small donation to help fund further development.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers