Segfault when trying to manage symbol libraries from main window

Bug #1782761 reported by Leandro Heck on 2018-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Critical
Jeff Young

Bug Description

Running from the terminal...

[1] 22145 segmentation fault kicad

Version: 6.0.0-rc1-unknown-da35b16~65~ubuntu18.04.1, release build

Actions:

Kicad (Main Window) > Preferences > Manage Symbol Libraries...

>>>>>>>> GDB Output

(gdb) start
Function "main" not defined.
Make breakpoint pending on future shared library load? (y or [n]) n
Starting program: /usr/bin/kicad
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Gtk-Message: 10:43:58.447: Failed to load module "canberra-gtk-module"
[New Thread 0x7fffe4cb2700 (LWP 22900)]
[New Thread 0x7fffdffff700 (LWP 22901)]
[New Thread 0x7fffdf7fe700 (LWP 22902)]
[New Thread 0x7fffdeffd700 (LWP 22903)]
[Thread 0x7fffdeffd700 (LWP 22903) exited]

Thread 1 "kicad" received signal SIGSEGV, Segmentation fault.
0x0000555555602fc3 in ?? ()
(gdb)

Leandro Heck (leoheck) on 2018-07-20
description: updated
Jeff Young (jeyjey) on 2018-07-20
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: New → In Progress
importance: Undecided → Critical
Jeff Young (jeyjey) on 2018-07-20
Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers