Update PCB from Schematic broke nets

Bug #1782660 reported by Hildo Guillardi Júnior on 2018-07-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
Critical
Jeff Young

Bug Description

Update PCB from Schematic broke nets or parts wires like that there are not any connection.
From the file *.net works normal.

This error is on last Nightly 6.0rc1 Ubuntu16.04.

Application: kicad
Version: 6.0.0-rc1-unknown-829ba27~65~ubuntu16.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-130-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Seth Hillbrand (sethh) wrote :

Note that this works correctly in 5.0

Also, the net connections are different when selecting different "Match Methods"

Changed in kicad:
importance: Undecided → Critical
milestone: none → 5.1.0
status: New → Confirmed
Jeff Young (jeyjey) wrote :

Actually, this has never worked. The difference in 6.0 is that it defaults to Delete Single Pad Nets, which is the broken code. If you turn that off then it runs the 5.0 algorithm.

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 65f4743a44a6a4167ce2f71ec911bf6840a20bdb
https://git.launchpad.net/kicad/patch/?id=65f4743a44a6a4167ce2f71ec911bf6840a20bdb

Changed in kicad:
status: In Progress → Fix Committed
Seth Hillbrand (sethh) wrote :

Hi Jeff- I just tried to recreate this with 5.0 and can't. Was there something in v5 that we need to fix for 5.0.1?

No, 5.0 hard-codes Delete Single Pad Nets to false, so the buggy code is never executed.

Cheers,
Jeff.

> On 22 Jul 2018, at 17:01, Seth Hillbrand <email address hidden> wrote:
>
> Hi Jeff- I just tried to recreate this with 5.0 and can't. Was there
> something in v5 that we need to fix for 5.0.1?
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1782660
>
> Title:
> Update PCB from Schematic broke nets
>
> Status in KiCad:
> Fix Committed
>
> Bug description:
> Update PCB from Schematic broke nets or parts wires like that there are not any connection.
> From the file *.net works normal.
>
> This error is on last Nightly 6.0rc1 Ubuntu16.04.
>
> Application: kicad
> Version: 6.0.0-rc1-unknown-829ba27~65~ubuntu16.04.1, release build
> Libraries:
> wxWidgets 3.0.2
> libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
> Platform: Linux 4.4.0-130-generic x86_64, 64 bit, Little endian, wxGTK
> Build Info:
> wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
> Boost: 1.58.0
> OpenCASCADE Community Edition: 6.8.0
> Curl: 7.47.0
> Compiler: GCC 5.4.0 with C++ ABI 1009
>
> Build settings:
> USE_WX_GRAPHICS_CONTEXT=OFF
> USE_WX_OVERLAY=OFF
> KICAD_SCRIPTING=ON
> KICAD_SCRIPTING_MODULES=ON
> KICAD_SCRIPTING_WXPYTHON=OFF
> KICAD_SCRIPTING_ACTION_MENU=ON
> BUILD_GITHUB_PLUGIN=ON
> KICAD_USE_OCE=ON
> KICAD_USE_OCC=OFF
> KICAD_SPICE=ON
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1782660/+subscriptions

@Jeff
I still having some issue related with this in a "201807270649+0cca1c6~65~ubuntu16.04.1", to reproduce:

1) Use GNDD and GNDA net symbols;
2) Connect some component do one of them;
3) Synchronize the PCB (not matter the way);
4) Change the GNDD<->GNDA at one component but keep both existing in the board;
5) Synchronize directly by F8, it not change at the PCB;

6) Creating the NET file works fine.

Should I change the bug status? Someone is experimenting this?

Jeff Young (jeyjey) wrote :

@Hildo, if this still happens to you can you post a very simple project which illustrates it? I can't seem to reproduce it....

Changed in kicad:
status: Fix Committed → New

Working now.
This last issue was cause by https://bugs.launchpad.net/kicad/+bug/1787380
that didn't allow my Linux to get last commits.

Changed in kicad:
status: New → Fix Released
Jeff Young (jeyjey) wrote :

Cool. Thanks for checking.

Jeff Young (jeyjey) wrote :

@Hildo, FYI our workflow is to leave the status as Fix Committed until an official release. (In other words the nightlies don't count as "Released".)

Thanks for your contributions to Kicad!

Changed in kicad:
status: Fix Released → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers