[5.0.0-rc3] Mouse has to be moved between filling and deleting copper areas

Bug #1781599 reported by Frank on 2018-07-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Unassigned

Bug Description

When you want to fill copper areas and right afterwards to remove that again, you have to first press "B" and afterwards "Ctrl+B". But when you press "Ctrl+B" after hitting "B", you will see that nothing happens. Instead, you first have to move the mouse – only then "Ctrl+B" works as expected.

Frank (zyklon87) wrote :
Nick Østergaard (nickoe) wrote :

This is beacause the window focus changes, caused by the progress dialog.

Frank (zyklon87) wrote :

Is this fixable? (I don’t see any dialog…?)

tags: added: pcbnew
Changed in kicad:
importance: Undecided → Low
milestone: none → 5.1.0
status: New → Confirmed
Seth Hillbrand (sethh) wrote :

This appears to be fixed in the current master. @Frank- Can you confirm that this works for you?

Changed in kicad:
status: Confirmed → Incomplete
Frank (zyklon87) wrote :

Currently I’m incredibly busy, I’ll try to test that next week!

Maciej Suminski (orsonmmz) wrote :

I also cannot reproduce the problem, marking as fixed to reduce noise on the bug tracker.

Changed in kicad:
status: Incomplete → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers