GAL canvas: Cannot delete footprint text

Bug #1781226 reported by John Beard on 2018-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

In the GAL canvas, text sub-items of footprints (for example the ref-des on the Fab layer) cannot be deleted, either with the delete key, or the context menu. This is possible in Legacy and there is a menu item indicating this should work.

Is this supposed to be possible, or should the menu item "Delete" be disabled in this case to indicate it is not?

Application: kicad
Version: (5.0.0-rc3-dev-2-g14ce51820), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.60.0 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.4) nghttp2/1.31.1
Platform: Linux 4.17.2-1-ARCH x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.67.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.60.0
    Compiler: GCC 8.1.1 with C++ ABI 1012

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

description: updated
John Beard (john-j-beard) wrote :
Wayne Stambaugh (stambaughw) wrote :

I guess the real question is do we want to allow editing of footprint elements in the board editor. If the answer is yes then we should implement the correct behavior in the gal canvas. If the answer is no, then we should remove that "feature" from the legacy canvas and grey out or remove those context menu entries.

Changed in kicad:
status: New → Confirmed
status: Confirmed → Triaged

Here is my opinion:
A footprint should be edited only from the footprint editor, especially to avoid bloat and duplcate code.

So we should remove footprint edition from the board editor (in legacy mode)
Exactly, only footprint field value, position and size can be modified from the board editor

On 7/11/2018 2:13 PM, jean-pierre charras wrote:
> Here is my opinion:
> A footprint should be edited only from the footprint editor, especially to avoid bloat and duplcate code.
>
> So we should remove footprint edition from the board editor (in legacy mode)
> Exactly, only footprint field value, position and size can be modified from the board editor
>

Interestingly, the code to do this is in PCB_BASE_FRAME so the same code
is called from both PCB_EDIT_FRAME and FOOTPRINT_EDIT_FRAME so the bloat
risk is low unless someone has implemented it somewhere else (which they
shouldn't have). Since we do allow for rotating text and changing text
width, height, thickness, etc from the board editor, deleting the text
does not seem terribly out of place. I can live with either choice.
FYI, I already have fix for the undo issue ready if we decide to
continue to allow this behavior. Of course this still doesn't resolve
the difference in behavior of the modern canvas.

Jeff Young (jeyjey) wrote :

I slightly prefer allowing deleting in the board editor. But I don’t feel strongly.

Michael.S.G (ozfalcon) wrote :

I prefer allowing deleting, From the point of view that footprint editing is more for amending pin or silk layers.
And Rotate/Size/Delete text is more just cosmetic changes more suited for pcbedit work.

John Beard (john-j-beard) wrote :

I am neutral on text deleting.

Against allowing: you can still hide any text (not just ref des and value). Not that consistent to allow deleting text and not other elements of a FP.

For allowing: module text is already "special" in that it can be moved and edited at will from Pcbnew: e.g. graphical lines can't be selected or changed at all from Pcbnew. Deletion is consistent with being able to independently move and edit an element.

Wayne Stambaugh (stambaughw) wrote :

For the sake of consistency with the legacy canvas, we should implement this in the modern canvas because user expect there to be some continuity. We can defer this to v5.1 or later.

Changed in kicad:
importance: Undecided → Low
milestone: none → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision a40ab768fc9e56a232a0cb4e0b2a40e08ade6b00
https://git.launchpad.net/kicad/patch/?id=a40ab768fc9e56a232a0cb4e0b2a40e08ade6b00

Changed in kicad:
status: Triaged → Fix Committed
assignee: nobody → Jeff Young (jeyjey)
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers