Wishlist: Add "Manage Symbol Libraries..." and "Manage Footprint Libraries..." options to the main KiCad screen's "Preferences" menu

Bug #1780604 reported by Gabriel Staples on 2018-07-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Wishlist
Jeff Young

Bug Description

Application: kicad
Version: 5.0.0-rc2-dev-unknown-f73b9a5~65~ubuntu14.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.35.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3
Platform: Linux 4.4.0-112-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.54.0
    Curl: 7.35.0
    Compiler: GCC 4.8.4 with C++ ABI 1002
Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_SPICE=ON

-----------------------------------

Currently from Eeschema you can go to Preferences --> Manage Symbol Libraries... and from Pcbnew you can go to Preferences --> Manage Footprint Libraries...

This makes sense, so leave these parts as they are. However, it also makes a lot of sense to add both of these options to the main KiCad screen's Preferences menu.

Please do that. Thanks!

Jeff Young (jeyjey) wrote :

5.1 has a unified preferences dialog.

However, the Library Tables are one thing I did NOT move to the unified dialog because they edit both preference information (global table) and project information (project table).

We could just hold our noses at that and move them to the unified dialog, or we could implement this suggestion....

Wayne Stambaugh (stambaughw) wrote :

@Jeff, it doesn't make sense to move the library table dialog into the unified preferences dialog unless you split the global and project specific tables. I'm not sure how well this would work in practice. I don't think I would want to open two different dialogs to tweak my library tables.

Gabriel Staples (ercaguy) wrote :

I think I'm following roughly what the problem is. What if you just greyed out the Project settings if the preferences dialog was opened globally without a project also open?

Jeff Young (jeyjey) wrote :

@Wayne, yeah, that's sort of where I ended up.

@eRCaGuy, that's the "hold our noses" option. I'm not really opposed to it, but on balance I think I'd rather just implement your original suggestion.

Wayne Stambaugh (stambaughw) wrote :

@Jeff, I'm fine with adding menu entries for the symbol and footprint library table edit dialogs to the KiCad preferences menu. Although coding this may be tricky because the PROJECT object is compiled depending on whether EESCHEMA or PCBNEW is defined effectively making PROJECT schematic or board specific (see include/project.h). I would like to see this changed but there may be some implications removing them.

Jeff Young (jeyjey) on 2018-07-19
Changed in kicad:
status: New → In Progress
assignee: nobody → Jeff Young (jeyjey)
milestone: none → 5.1.0
importance: Undecided → Wishlist
Jeff Young (jeyjey) on 2018-07-19
Changed in kicad:
status: In Progress → Fix Committed
Maciej Suminski (orsonmmz) wrote :

Jeff, I think SCH_EDIT_FRAME needs to implement InstallLibraryTablesPanel(). Right now, nothing calls DIALOG_EDIT_LIBRARY_TABLES::InstallPanel(), so Symbol Library Table dialog crashes when invoked from the launcher window.

Jeff Young (jeyjey) wrote :

D'oh. I was so excited that I finally got it to work that I forgot to implement the other half.

Changed in kicad:
status: Fix Committed → In Progress
Maciej Suminski (orsonmmz) wrote :

No worries, we are all humans, though I suspect there are also a few cyborgs in our community.

Jeff Young (jeyjey) on 2018-07-20
Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers