KiCad crashes when trying to display help when a "locale" is specified

Bug #1780537 reported by Olivier on 2018-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

Hello,

I run Debian linux with locale "LANG=fr_FR.utf8" and KiCad version "5.0.0-rc2+dfsg1-3".

When I do "KiCad > Aide > Manuel de KiCad", the help page is correctly displayed in my web browser ("file:///usr/share/doc/kicad/help/fr/kicad.html").

Now I want to run everything in English and do the same. Of course, I have package "kicad-doc-en" installed ("file:///usr/share/doc/kicad/help/en/kicad.html" is present).

=> I run "LANG=c kicad" and I click "KiCad > Help > KiCad Manual".
PROBLEM : The program crashes instead of displaying the help file in the web browser.

ASSERT INFO:
../src/common/filename.cpp(2025): assert "Assert failure" failed in IsValidDirComponent(): empty directory passed to wxFileName::InsertDir()

BACKTRACE:
[1] wxFileName::IsValidDirComponent(wxString const&)
[2] wxFileName::AppendDir(wxString const&)
[3] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[4] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[5] wxEvtHandler::TryHereOnly(wxEvent&)
[6] wxEvtHandler::DoTryChain(wxEvent&)
[7] wxEvtHandler::ProcessEvent(wxEvent&)
[8] wxWindowBase::TryAfter(wxEvent&)
[9] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[10] wxMenuBase::SendEvent(int, int)
[11] g_closure_invoke
[12] g_signal_emit_valist
[13] g_signal_emit
[14] gtk_widget_activate
[15] gtk_menu_shell_activate_item
[16] g_closure_invoke
[17] g_signal_emit_valist
[18] g_signal_emit
[19] gtk_propagate_event
[20] gtk_main_do_event
[21] g_main_context_dispatch
[22] g_main_loop_run
[23] gtk_main
[24] wxGUIEventLoop::DoRun()
[25] wxEventLoopBase::Run()
[26] wxAppConsoleBase::MainLoop()
[27] wxEntry(int&, wchar_t**)
[28] __libc_start_main
[29] _start

My Debian packages are:
kicad 5.0.0~rc2+dfsg1-3
kicad-common 5.0.0~rc2+dfsg1-3
kicad-demos 5.0.0~rc2+dfsg1-3
kicad-doc-en 5.0.0~rc2+dfsg1-3
kicad-doc-fr 5.0.0~rc2+dfsg1-3
kicad-footprints 5.0.0~rc2-2
kicad-libraries 5.0.0~rc2+dfsg1-3
kicad-symbols 5.0.0~rc2-2
kicad-templates 5.0.0~rc1-2

Best regards,

Olivier

Seth Hillbrand (sethh) wrote :

I'm unable to recreate.

@Oliver does this still happen?

Changed in kicad:
status: New → Incomplete
Nick Østergaard (nickoe) wrote :

I thought it should be a big C in the LANG export, I guess it does not matter.

Launchpad Janitor (janitor) wrote :

[Expired for KiCad because there has been no activity for 60 days.]

Changed in kicad:
status: Incomplete → Expired
Olivier (oc-spam66) wrote :

Hello,

I checked again after the suggestion given above by Nick:

$ LANG=c kicad # -> crashes when I do "Help > KiCad Manual"
$ LANG=C kicad # -> works when I do "Help > KiCad Manual"

So it appears that the case of the "c" matters and it should be "C".
Crashing due to this typo seems to be an exaggerated consequence, don't you think?

Olivier (with KiCad version 5.0.0+dfsg1-2)

Seth Hillbrand (sethh) wrote :

This appears to be fix committed in 5.1

Changed in kicad:
milestone: none → 5.1.0
status: Expired → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers