eeschema: Assertion failure on add text

Bug #1780478 reported by tpkuester on 2018-07-06
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KiCad
Low
Unassigned

Bug Description

What Happened:
When attempting to place text on the schematic, an assertion failure dialog box pops up. The text can be placed after clicking "continue".

Expected Behavior:
No assertion failures! ;)

Steps to Reproduce:
 - Create a new schematic (or use an existing one)
 - Click the "Place text" button on the right toolbar
 * An assertion message should appear
 - Clear the assertion by clicking "Continue"
 - Enter some text in the box, and click "OK"
 - Place the text by clicking on the schematic

Hope this information is useful! Thanks for the development effort!

------------------

Build information:

Running on Ubuntu 16.04.04, installed via the Kicad 5 PPA.

Application: kicad
Version: (5.0.0-rc2-205-g9d1b569), release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.47.0 GnuTLS/3.4.10 zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.16.13-041613-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.58.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.47.0
    Compiler: GCC 5.5.0 with C++ ABI 1009

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

------------------

Backtrace:

ASSERT INFO:
../src/common/sizer.cpp(1961): assert "!IsRowGrowable( idx )" failed in AddGrowableRow(): AddGrowableRow() called for growable row

BACKTRACE:
[1] wxFlexGridSizer::AddGrowableRow(unsigned long, int)
[2] wxDialog::Show(bool)
[3] wxDialog::ShowModal()
[4] wxAppConsoleBase::CallEventHandler(wxEvtHandler*, wxEventFunctor&, wxEvent&) const
[5] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[6] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[7] wxEvtHandler::TryHereOnly(wxEvent&)
[8] wxEvtHandler::ProcessEventLocally(wxEvent&)
[9] wxEvtHandler::ProcessEvent(wxEvent&)
[10] wxScrollHelperEvtHandler::ProcessEvent(wxEvent&)
[11] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[12] g_closure_invoke
[13] g_signal_emit_valist
[14] g_signal_emit
[15] gtk_propagate_event
[16] gtk_main_do_event
[17] g_main_context_dispatch
[18] g_main_loop_run
[19] gtk_main
[20] wxGUIEventLoop::DoRun()
[21] wxEventLoopBase::Run()
[22] wxAppConsoleBase::MainLoop()
[23] APP_KICAD::OnRun()
[24] wxEntry(int&, wchar_t**)
[25] main
[26] __libc_start_main
[27] _start

tpkuester (tpkuester) wrote :

Great scott! I just realized I was running an old version I had installed, not Kicad from the PPA! This bug does not exist in 5.0.0-rc3-6a2723a~65~ubuntu16.04.1, release build

My apologies. I tried to close this, but can't quite figure out how.

description: updated
Seth Hillbrand (sethh) on 2018-07-06
Changed in kicad:
status: New → Fix Committed

I get the assert only with the debug build.

Application: kicad
Version: (5.0.0-rc3-dev-5-g18c98c558-dirty), debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.60.0 GnuTLS/3.5.18 zlib/1.2.11 libidn2/2.0.4 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.32.0 librtmp/2.3
Platform: Linux 4.16.0-2-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.60.0
    Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Nick Østergaard (nickoe) wrote :

I set the status to few, as we only expect to see asserts if debug is enabled, so the bug is probably still there lurking.

tags: added: eeschema
Changed in kicad:
status: Fix Committed → New
Jeff Young (jeyjey) wrote :

The bug is fixed in my 5.1 tree, but only as a side-effect of rewriting that dialog (ie: there's no patch we could merge to 5.0 or 5.0.1).

How bad do we consider debug-asserts? Do we want to queue this up for 5.0 or 5.0.1, or do we figure that anyone doing a debug build can just comment out the assert?

Wayne Stambaugh (stambaughw) wrote :

Does this assert cause any issues when you ignore it? If not, it can be removed whenever we get around to it so I'm fine with waiting until 5.1. If so, then we should fix it.

Seth Hillbrand (sethh) wrote :

The assert is in wx. It appears we have a malformed row parameter in our flexgrid definition. I don't see issues with ignoring it on Linux.

tpkuester (tpkuester) wrote :

Wayne, no issues after ignoring the asset! (I've also switched over to using what's in the PPA, and everything is working swimmingly. Step/iges support is phenomenal!)

Attila Kinali (attila-3) wrote :

I just run into the same problem using the debian packages for rc3 (5.0.0~rc3+dfsg1-1). Just klicking it away is fine. Unfortunately, if you press escape (to leave the dialog without doing anything), wx interprets this as pressing "Stop" and thus dumping kicad's core.... So I would recommend to fix this before the release to not annoy unsuspecting users too much.

Wayne Stambaugh (stambaughw) wrote :

@Attila, the escape key behavior is wxWidgets so there is not much we can do about that. The reason I'm not in any great hurry to fix this is that we typically on provide release builds so typical users will never see this issue. Developers using debug builds should know how to handle this. Since Jeff already has this fixed in his 5.1 branch, I am happy waiting for that to get merged into the development branch rather than duplicating the effort.

Changed in kicad:
status: New → Triaged
importance: Undecided → Low
milestone: none → 5.1.0
Jeff Young (jeyjey) wrote :

Marking this to fix committed (as I used to see it on my branch too -- although it's possible it might be platform-specific). Anyway, if anyone still sees it in 5.1 or 6.0, please set back to New.

Changed in kicad:
status: Triaged → Fix Committed
Manuel R. (fusedfet) wrote :

Hello,
I ran into this issue on the v5 release build:

Application: kicad
Version: (5.0.0), release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Nick Østergaard (nickoe) wrote :

@Manuel, please redownload the lastet windows build if you are still experiencing issues.

Wedge (wedge-ageek) wrote :

This is happening with the Debian testing build as well. I've had it happen when adding labels too.

Application: kicad
Version: 5.0.0+dfsg1-1, release build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.60.0 OpenSSL/1.1.0f zlib/1.2.8 libpsl/0.17.0 (+libidn2/0.16) libssh2/1.7.0 nghttp2/1.18.1 librtmp/2.3
Platform: Linux 4.9.0-7-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.60.0
    Compiler: GCC 8.1.0 with C++ ABI 1013
Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=OFF

Seth Hillbrand (sethh) wrote :

Linking this report to the Debian bug report for this issue at

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909282

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.