footprint editor, /edit/delete gives unknown action

Bug #1778202 reported by Nicholas Savenlid on 2018-06-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

hi

i was looking for deleting a footprint , that would preferably be under /file

but anyway, i am not sure what the /edit/delete is supposed to do, hard to describe, you need to try it.

Application: kicad
Version: (5.0.0-rc2-178-g3c7b91b96), release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    OpenCASCADE Community Edition: 6.8.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

Nicholas Savenlid (nicholas-z) wrote :

it was obviously a eraser-gum ?

funny

sorry about that

Changed in kicad:
status: New → Invalid
Nicholas Savenlid (nicholas-z) wrote :

but not even in library browser you can delete footprints

Jeff Young (jeyjey) wrote :

I'd still call that a bug. Tools don't belong in the Edit menu. (And do we really want a delete tool? Sounds like a hang-over from before we had selections.)

Changed in kicad:
status: Invalid → Confirmed
importance: Undecided → Low

Forgot to mention: to delete a footprint in the Footprint Editor use the trash-can icon in the toolbar.

> On 22 Jun 2018, at 06:03, Nicholas Savenlid <email address hidden> wrote:
>
> but not even in library browser you can delete footprints
>
> --
> You received this bug notification because you are a member of KiCad Bug
> Squad, which is subscribed to KiCad.
> https://bugs.launchpad.net/bugs/1778202
>
> Title:
> footprint editor, /edit/delete gives unknown action
>
> Status in KiCad:
> Invalid
>
> Bug description:
> hi
>
> i was looking for deleting a footprint , that would preferably be
> under /file
>
> but anyway, i am not sure what the /edit/delete is supposed to do,
> hard to describe, you need to try it.
>
> Application: kicad
> Version: (5.0.0-rc2-178-g3c7b91b96), release build
> Libraries:
> wxWidgets 3.0.3
> libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
> Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
> Build Info:
> wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
> Boost: 1.60.0
> OpenCASCADE Community Edition: 6.8.0
> Curl: 7.54.1
> Compiler: GCC 7.1.0 with C++ ABI 1011
>
> Build settings:
> USE_WX_GRAPHICS_CONTEXT=OFF
> USE_WX_OVERLAY=OFF
> KICAD_SCRIPTING=ON
> KICAD_SCRIPTING_MODULES=ON
> KICAD_SCRIPTING_WXPYTHON=ON
> KICAD_SCRIPTING_ACTION_MENU=ON
> BUILD_GITHUB_PLUGIN=ON
> KICAD_USE_OCE=ON
> KICAD_USE_OCC=OFF
> KICAD_SPICE=ON
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/kicad/+bug/1778202/+subscriptions

Nicholas Savenlid (nicholas-z) wrote :

thanks Jeff

i know, done it a 1000 times, its just that i lost my memory completely for 5 minutes and started to look in places where i would typically find save/open/delete (namely under /file )

:-)

Jeff Young (jeyjey) wrote :

As long as no one objects, I'm going to remove the Eraser Tool in 5.1, and wire up Edit > Delete to do a normal delete of the selected items.

Changed in kicad:
milestone: none → 5.1.0
assignee: nobody → Jeff Young (jeyjey)
Jeff Young (jeyjey) on 2018-07-26
Changed in kicad:
status: Confirmed → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 0cca1c6721f72455cae505339ed1d93ac3ee90d8
https://git.launchpad.net/kicad/patch/?id=0cca1c6721f72455cae505339ed1d93ac3ee90d8

Changed in kicad:
status: In Progress → Fix Committed
Nicholas Savenlid (nicholas-z) wrote :

Ohhh
I am so excited.
So thrilled now that 5.0 is out.
Great job by all of you BTW.

I will donate ASA get in front of a real computer.
(Monday)

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers