eeschema: typo in config file color definition

Bug #1777927 reported by endofexclusive on 2018-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

Brighened -> Brightened

kicad$ git describe --tags
5.0.0-rc2-187-g8394e2b71
kicad$ git grep -i brighened
eeschema/eeschema.cpp: CLR( "Color4DBrighenedEx", LAYER_BRIGHTENED, COLOR4D( PUREMAGENTA ) )

This string is written to and read from the file in $KICAD_CONFIG_HOME/eeschema. The issue is minor, but could cause confusion when editing colors manually in config file. Or possibly when sharing palettes with friends.

Since fixing this changes a file format, I would assume it has to wait until after KiCad 5.0 has been released.

endofexclusive (endofexclusive) wrote :
description: updated
Jeff Young (jeyjey) wrote :

Note that the 6.0 tree also has a way to specify a legacy key for configs so that it will read the legacy key if the current key isn't found.

Changed in kicad:
status: New → Triaged
importance: Undecided → Low
milestone: none → 6.0.0-rc1
Jeff Young (jeyjey) on 2018-06-28
Changed in kicad:
milestone: 6.0.0-rc1 → 5.1.0
Jeff Young (jeyjey) wrote :

@endofexclusive, I'm merging your patch. Thanks for your contribution to Kicad!

Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: Triaged → In Progress
Nick Østergaard (nickoe) wrote :

Fixed in f3983cc47f0d61971dd156dfa2bdb52fd7d5049b master

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers