Field Editor does not save if field doesnt exist on symbol already

Bug #1765443 reported by José I. Romero on 2018-04-19
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
High
Jeff Young

Bug Description

The field editor does not save changes made to fields that aren't in the specific symbol already.

Look at the attached screenshot, if i write into any of the blank fields and hit OK, the editor SILENTLY DROPS IT. Hitting cancel will also discard all changes silently with no confirmation at all.

Application: kicad
Version: (5.0.0-rc2-dev-470-g442d1169a), release build
Libraries:
    wxWidgets 3.0.2
Platform: Linux 4.9.0-6-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    Compiler: GCC 6.3.0 with C++ ABI 1010

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=OFF
    KICAD_USE_OCE=ON
    KICAD_SPICE=OFF

Changed in kicad:
milestone: none → 5.0.0-rc2
Jeff Young (jeyjey) on 2018-04-19
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
importance: Undecided → High
status: New → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 9201417c06e1b8cac5197e8e03a74d0233462642
https://git.launchpad.net/kicad/patch/?id=9201417c06e1b8cac5197e8e03a74d0233462642

Changed in kicad:
status: In Progress → Fix Committed
Jeff Young (jeyjey) wrote :

> Hitting cancel will also discard all changes silently
> with no confirmation at all.

This change is by design. It follows the user interface guidelines for the various platforms, which the previous version did not.

José I. Romero (jose-cyborg) wrote :

It is very user-hostile to allow someone to spend hours working on something to later allow it to be all lost by pressing a button that is right next to the save button with no confirmation nor indication. The field editor is an edit view very much like the schematic or pcb editor and it should confirm before dropping a big mass of unsaved changes.

Jeff Young (jeyjey) wrote :

One could argue that it /should/ be a view, but it's presented (and implemented) as a modal dialog.

Note that because it's a modal dialog, the data isn't applied to the schematic until you hit OK, so an autosave isn't going to capture it either. In short, it's not a good idea to collect a big lump of unsaved changes anywhere. With that in mind I've added an "Apply, Save Schematic and Continue" button as we have in CvPcb. They're not pretty, but they'll have to hold the fort until these dialogs can be implemented as views.

José I. Romero (jose-cyborg) wrote :

I'm ok with this compromise, more thought is needed for V6

José I. Romero (jose-cyborg) wrote :

@jeff, for the record, i just lost 20 more minutes of work because i hit escape once too many in the field editor. Thank you.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers