DRC should check for track/zone collisions

Bug #1762474 reported by Jeff Young on 2018-04-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KiCad
High
Jeff Young

Bug Description

Spun out from https://bugs.launchpad.net/kicad/+bug/1760097 (which was closed with the 5.0 stop-gap measure).

Jeff Young (jeyjey) on 2018-04-09
description: updated
Changed in kicad:
status: New → Triaged
milestone: none → 6.0.0-rc1
Jeff Young (jeyjey) on 2018-05-02
Changed in kicad:
importance: Undecided → Medium
Jeff Young (jeyjey) on 2018-07-16
Changed in kicad:
importance: Medium → High
Mikkel Jeppesen (mikkeljep) wrote :

Could a possible fix be to run a test zone-fill (that doesn't actually get applied) and test if the zone is different from the current zone?

Mikkel Jeppesen (mikkeljep) wrote :

That change was not intentional. I didn't expect to have the ability to change status, and as I'm new to launchpad, I thought it'd take me to a fix that had been committed, sorry.

Changed in kicad:
status: Triaged → Fix Released
Jeff Young (jeyjey) wrote :

No worries; I set it back for you.

Changed in kicad:
status: Fix Released → Triaged
Maciej Suminski (orsonmmz) wrote :

Mikkel, actually this is the the current behavior. If a zone is not update you will get a notification when you launch DRC (5.0 and up).

Jeff Young (jeyjey) on 2018-08-24
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: Triaged → In Progress
milestone: 6.0.0-rc1 → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 0e3919e7aa059875fd6a50be0b08f8c8805ed308
https://git.launchpad.net/kicad/patch/?id=0e3919e7aa059875fd6a50be0b08f8c8805ed308

Changed in kicad:
status: In Progress → Fix Committed
Jeff Young (jeyjey) wrote :

We now check against the zone outline for unfilled zones, and the fill polygons for filled (but possibly out-of-date) zones.

Miljan Pakovic (offrider) wrote :

Hi Jeff,

Could you please take a look at this pcb which I put in attachment?
The problem is that DRC does not detect obvious violation between track and zone at x=185.6486 y=99.39 (U1-pin14).

Many thanks,
Miljan

Miljan Pakovic (offrider) wrote :

Thanks to the kindness of Sir Jean-Pierre Charras the issue seems to be solved by his commit 90178eb681.

Cheers,
Miljan

Jeff Young (jeyjey) wrote :

Thanks for letting us know, Miljan.

Cheers,
Jeff.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments