User model issues editing aliased symbols

Bug #1744773 reported by Jeff Young on 2018-01-22
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
KiCad
Low
Jeff Young

Bug Description

The tree control always shows the root symbol as selected, even when an alias is being edited.

The value field is always rendered on the canvas with the root symbol value, even when an alias is being edited.

Some fields are auto-generated: the value is generated from the name, and the datasheet is generated from the document filename. The value field is read-only in the field properties dialog, which reinforces this model, but the datasheet field is read-write (which does not).

They should both be read-only, with perhaps the button below them replaced with explanatory text ("auto-filled from symbol name" / "auto-filled from document filename" or something to that effect).

They should also show the current alias values. The value field currently always shows the root value, while the datasheet field always shows empty.

Jeff Young (jeyjey) on 2018-01-22
description: updated
Jeff Young (jeyjey) wrote :

Application: kicad
Version: (2018-01-21 revision b6bb32fa7)-master, debug build
Libraries:
    wxWidgets 3.0.4
    libcurl/7.54.0 LibreSSL/2.0.20 zlib/1.2.11 nghttp2/1.24.0
Platform: Mac OS X (Darwin 17.3.0 x86_64), 64 bit, Little endian, wxMac
Build Info:
    wxWidgets: 3.0.4 (UTF-8,STL containers,compatible with 2.8)
    Boost: 1.66.0
    Curl: 7.57.0
    Compiler: Clang 9.0.0 with C++ ABI 1002

Build settings:
    USE_WX_GRAPHICS_CONTEXT=ON
    USE_WX_OVERLAY=ON
    KICAD_SCRIPTING=OFF
    KICAD_SCRIPTING_MODULES=OFF
    KICAD_SCRIPTING_WXPYTHON=OFF
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=OFF
    KICAD_SPICE=ON

description: updated
description: updated
Jeff Young (jeyjey) on 2018-02-19
Changed in kicad:
status: New → Triaged
importance: Undecided → Low
milestone: none → 6.0.0-rc1
NhatKhai (nhatkhai) wrote :

I'm thinking about that on default all alias field values share with the original one up-to until they are got modified in the editing mode on per alias. For may case, I have custom field for supplier with item# and prices, or the detail info that most the time are difference from each others. So alias item should accept it own values instead.

And I would think the datasheet field should only out filled with Documentation File Name if the value field did not change by user or should make the Documentation File Name and datasheet field as of one single thing. But currently, I'm using the Documentation File Name to point to a local pdf file with relative path, and using the datasheet field point to the http link. this way, in have two option to work with the symbol online/offline. And the offline file act as backup file if in case the manufacture change there datasheet link.

NhatKhai (nhatkhai) wrote :

Another note (I don't know where else to share) is that: I note that footprint library lack of customize field, so I use to use some drawing layer text with hidden properties to add information about where the footprint draw base on what datasheet, and some other quick simple dimension to help me on selection of footprint and minimize errors. I don't know if this should be a discuss on forum or not. But it not a bug, just a info for active developer....

Jeff Young (jeyjey) on 2018-08-13
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
milestone: 6.0.0-rc1 → 5.1.0
Jeff Young (jeyjey) on 2018-08-13
Changed in kicad:
status: Triaged → In Progress
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision d72fdaed299abb525dc0ef872b6db652940465c5
https://git.launchpad.net/kicad/patch/?id=d72fdaed299abb525dc0ef872b6db652940465c5

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers