footprint editor: Pad copy doesn't copy local clearance data

Bug #1743141 reported by Romain on 2018-01-13
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KiCad
Medium
Jeff Young

Bug Description

Using:
Application: kicad
Version: (2017-11-21 revision 8de70f3dd)-makepkg, release build
Libraries:
    wxWidgets 3.0.3
    libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    Curl: 7.54.1
    Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_SPICE=ON

In the footprint editor, I added a new pad (default shape) and then used the "Pads - Copy Pad Settings" on pad 4 to paste it on pad 5 using "Pads - Apply Pad Settings".
All drill/shape info were filled-in, but the "Local Clearance and Settings" (second tab in the pad properties) were not updated.
Bug or feature? :)

Romain (romain145) wrote :
Nick Østergaard (nickoe) wrote :

Please provide kicad_pcb file with the footprint in it.

tags: added: pcbnew
Jeff Young (jeyjey) wrote :

Confirmed. General and Custom Shape Primitive tab properties are copied; Local Clearance and Settings tab properties are not.

(It's hard to make a case for this being "by design", so I'm going to label it "bug", at least until I examine the code....)

Changed in kicad:
status: New → Triaged
importance: Undecided → Medium
Jeff Young (jeyjey) on 2018-01-13
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
status: Triaged → In Progress
Jeff Young (jeyjey) wrote :

The plot thickens. The context menu items read "Copy Pad Settings" and "Apply Pad Settings". One could be forgiven for concluding that they mean using the clipboard. They do not.

Copy Pad Settings copies the settings into the board's Pad Properties (editable through the Dimensions > Pad Properties menu item). Apply Pad Settings (or creating a new pad) uses those settings.

I think we should:
1) change Dimensions > Pad Properties to Dimensions > Default Pad Properties
2) modify Copy Pad Settings / Apply Pad Settings to use a separate clipboard
3) add action buttons to the Edit Pad dialog to copy to/from the Default Pad Properties

This would allow both functions without creating ambiguity between them.

Jeff Young (jeyjey) on 2018-01-20
Changed in kicad:
status: In Progress → Confirmed
Jeff Young (jeyjey) on 2018-04-13
Changed in kicad:
milestone: none → 6.0.0-rc1
Jeff Young (jeyjey) wrote :

Default Pad Properties was removed from 5.1, which leaves Copy Pad Settings / Apply Pad Settings free to use the data structure.

Changed in kicad:
milestone: 6.0.0-rc1 → 5.1.0
status: Confirmed → In Progress
Jeff Young (jeyjey) on 2018-07-17
Changed in kicad:
status: In Progress → Fix Committed
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 45e6dfc7af1931fc774db90ebb14560a7674c801
https://git.launchpad.net/kicad/patch/?id=45e6dfc7af1931fc774db90ebb14560a7674c801

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers