Via Tool should honour DRC

Bug #1718827 reported by Strntydog on 2017-09-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KiCad
High
Seth Hillbrand

Bug Description

With DRC checking enabled, it shouldn't be possible to drop a via using the Via Tool, if
that via would cause a design violation.

Exactly like its not possible to lay two tracks with different nets over one another.

Example:
two tracks on different layers, with different nets. It should not be possible to put a via over them where they intersect, because thats a design violation.

Version:
Application: kicad
Version: no-vcs-found-e2505cb~60~ubuntu17.04.1, release build
Libraries:
    wxWidgets 3.0.2
    libcurl/7.52.1 OpenSSL/1.0.2g zlib/1.2.11 libidn2/0.16 libpsl/0.17.0 (+libidn2/0.16) librtmp/2.3
Platform: Linux 4.10.0-33-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
    Boost: 1.62.0
    Curl: 7.52.1
    Compiler: GCC 6.3.0 with C++ ABI 1010

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_SPICE=ON

Jeff Young (jeyjey) on 2018-04-05
Changed in kicad:
status: New → Triaged
importance: Undecided → Wishlist
Nick Østergaard (nickoe) wrote :

Please attach a board file where you placed the vias that you think should be prevented by online DRC.

tags: added: pns
removed: via

I confirm an incorrect behavior of the place via tool:
- It does not respect the DRC constraints.
- It does not create the intermediate points on tracks, mandatory for connectivity calculations.

Changed in kicad:
importance: Wishlist → Medium
status: Triaged → New
Jeff Young (jeyjey) wrote :

Second issue is a duplicate of https://bugs.launchpad.net/kicad/+bug/1737349.

Mentioning this just so that bug gets closed too if we fix it from this report.

Jeff Young (jeyjey) on 2018-04-08
Changed in kicad:
status: New → Triaged
Jeff Young (jeyjey) wrote :

The second issue was fixed. First issue remains.

Seth Hillbrand (sethh) on 2018-05-27
Changed in kicad:
assignee: nobody → Seth Hillbrand (sethh)
status: Triaged → In Progress
Jeff Young (jeyjey) on 2018-07-16
Changed in kicad:
importance: Medium → High
Seth Hillbrand (sethh) on 2018-07-16
Changed in kicad:
milestone: none → 5.1.0
KiCad Janitor (kicad-janitor) wrote :

Fixed in revision 4247e32cd6e9bfc00bb54a948e9f71f6799823ef
https://git.launchpad.net/kicad/patch/?id=4247e32cd6e9bfc00bb54a948e9f71f6799823ef

Changed in kicad:
status: In Progress → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers