DXF import placement origin not respected in GAL

Bug #1708537 reported by Nick Østergaard on 2017-08-03
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
KiCad
Low
Unassigned

Bug Description

With GAL canvases the DXF placement origin options does not fully apply, the object will be "attached" t the cursor instead of the specified origin point.

I think this was a bugfix added recently in GAL, but I think one should have that as a option in the dialog. Maybe call it "Place manually with cursor" or something similar.

The origin setting is respected in legacy.

Application: pcbnew
Version: (2017-08-03 revision 3570154ef)-master, debug build
Libraries: wxWidgets 3.0.3
           libcurl/7.54.1 OpenSSL/1.1.0f zlib/1.2.11 libpsl/0.17.0 (+libicu/59.1) libssh2/1.8.0 nghttp2/1.23.1
Platform: Linux 4.11.6-3-ARCH x86_64, 64 bit, Little endian, wxGTK
- Build Info -
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.64.0
Curl: 7.54.1
KiCad - Compiler: GCC 7.1.1 with C++ ABI 1011
        Settings: USE_WX_GRAPHICS_CONTEXT=OFF
                  USE_WX_OVERLAY=OFF
                  KICAD_SCRIPTING=ON
                  KICAD_SCRIPTING_MODULES=ON
                  KICAD_SCRIPTING_WXPYTHON=ON
                  KICAD_SCRIPTING_ACTION_MENU=ON
                  BUILD_GITHUB_PLUGIN=ON
                  KICAD_USE_OCE=ON

tags: added: al cern dxf import
tags: added: gal
removed: al
Seth Hillbrand (sethh) on 2018-06-09
Changed in kicad:
importance: Undecided → Low
status: New → Confirmed

@Nick, is this still an issue in 5.1.0? The Import DXF dialog was replaced with the Import Vector Graphics dialog late 2018/early 2019.

Nick Østergaard (nickoe) wrote :

It looks like it is working fine in
Version: (5.1.0-72-ga61126997), release build

Changed in kicad:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers