Update PCB from schematics does not delete duplicated components

Bug #1682970 reported by bkb on 2017-04-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
High
Jeff Young

Bug Description

Update PCB from schematics does not delete duplicated components
This is the issue:
https://www.youtube.com/watch?v=HgF4lGlRaTI

it is daily build from http://ppa.launchpad.net/js-reynaud/ppa-kicad/ubuntu

Application: kicad
Version: no-vcs-found-b321eff~58~ubuntu16.04.1, release build
Libraries: wxWidgets 3.0.2
           libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.8.0-46-generic x86_64, 64 bit, Little endian, wxGTK
- Build Info -
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.58.0
Curl: 7.47.0
KiCad - Compiler: GCC 5.4.0 with C++ ABI 1009
        Settings: USE_WX_GRAPHICS_CONTEXT=OFF
                  USE_WX_OVERLAY=OFF
                  KICAD_SCRIPTING=ON
                  KICAD_SCRIPTING_MODULES=ON
                  KICAD_SCRIPTING_WXPYTHON=ON
                  KICAD_SCRIPTING_ACTION_MENU=ON
                  BUILD_GITHUB_PLUGIN=ON
                  KICAD_USE_OCE=ON

bkb (bkb-b) on 2017-04-14
description: updated
Kristoffer (kristoffer-odmark) wrote :

This is still the case, and could be solved by treating duplicated items as "extra" items, that is, they should not contain a "sheet path", since they have none.

Changed in kicad:
status: New → Confirmed
Changed in kicad:
status: Confirmed → Opinion
Jeff Young (jeyjey) wrote :
Changed in kicad:
assignee: nobody → Jeff Young (jeyjey)
Jeff Young (jeyjey) wrote :

Re-opening so I can take a look at it for 6.0....

Changed in kicad:
status: Opinion → Confirmed
Jeff Young (jeyjey) wrote :

As indicated by Orson in the email linked to in #2, we can't delete the "extra" because we don't know which is the extra and which is the "good" one.

I have added an error for it though.

Changed in kicad:
importance: Undecided → High
Jeff Young (jeyjey) wrote :

Commit: ae5183f614bddf91f595127ffa19118b5c735ac9

Changed in kicad:
status: Confirmed → Fix Committed
milestone: none → 5.1.0
Jeff Young (jeyjey) wrote :

Also now fixed for the old Read Netlist path.

Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers