Grid dots too small on high DPI displays (Eeschema)

Bug #1660560 reported by Robert Nicoll on 2017-01-31
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

When using Eeschema on a Notebook PC a 14" 1440p (QHD) display the dots that make up the grid are unable to be seen with the naked eye at ordinary sitting distance.
When peering up close to the screen the green dots are visible.

Solutions could be to increase dot size, or make dots black, thus using all 3 (RGB) sub pixels.

Also mentioned in the forum by davidsrsb...
"High DPI displays are also the root cause of the hard to see unrouted connection lines in OpenGL canvas.
This will be an increasing problem as pixel size continues to shrink"

I'm new to KiCad thus am not familiar with this issue, but suspect it too to be relevant, and suspect i may come across it when the time comes.

Also a fair point made re pixel sizes shrinking, something that will need to be catered for in future.

Version Info...
Application: kicad
Version: 4.0.5 release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Robert Nicoll (virtual81) wrote :

Was hopeing to make this a wishlist item rather than a bug, couldn't seen an option to do so.

David Pearce (halzia) wrote :

Single pixel dots and one pixel wide lines are very hard to see on high PPI displays like some of the Apple Retina screens. It would be good to have some kind of optional minimum feature setting for these displays

Chris Pavlina (pavlina-chris) wrote :

Hell, they can be hard enough to see on a normal display if your vision isn't the best. You can change from a dot grid to a line grid - inexplicably this is hidden away in Dimensions -> Grid. It's more visible then. You may want to change the shade of the lines in the Visibles -> Render tab as the best one for dots isn't quite the same as the best one for lines.

Joan (joanthesparky) wrote :

Re: lines as dot replacement
Don't like lines, I want dots.
Probably not easy to come up with a programming solution though.
Only the one responsible for the OpenGL display (or others heavily involved) is probably able to judge if possible and how much work is involved..
Anyhow, as I wrote on KiCAD.info in regards to this - sooner or later even the developers will run into this and need to solve this for themselves. So yeah, I hope you all get high DPI displays in anot to distant future ;-)

tags: added: hdpi
Jeff Young (jeyjey) wrote :

The modern canvas (OpenGL) does support changing the size of the dots. We don't use that yet in eeschema, but it's coming in 6.0.

Since it will solve the problem, it's not likely anyone will expend the effort to fix it in the Legacy canvas.

The ratsnest problem is a different issue as we don't (at present) have a way to set its width. We're tracking that here: https://bugs.launchpad.net/kicad/+bug/1740156

Changed in kicad:
status: New → Won't Fix
Jeff Young (jeyjey) on 2019-05-10
Changed in kicad:
status: Won't Fix → Fix Committed
status: Fix Committed → Fix Released
Don Wills (donwills) wrote :

I'm new to Kicad. Just kicking the tires trying to decide Eagle vs Kicad. Using MacOS 10.14.5 on a 2017 iMac Pro with 27" Retina 5K monitor and Radeon Pro Vega 56 8GB. Kicad 5.1.4.

At first it appeared that grid dots and small crosses didn't work in Eeschema. On a hunch, I changed Grid thickness from the default 1.0 px to 2.0 px and all is well.

Suggestions:

1. Change the unit of measure for the Grid Style value from px to mils (or to some other device independent unit).

2. Make the default Grid thickness larger.

Also, I've been playing around with the Graphics (Accelerate) chooser preference in Eeschema. From what I can see, there is no difference whatsoever between any of the 5 choices. Is the meaning of this preference setting described anywhere?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers