Newly created component in library editor generates error upon restarting Kicad [Cause Identified]

Bug #1614691 reported by Mez on 2016-08-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KiCad
Undecided
Unassigned

Bug Description

I created a few components this afternoon in a library I have used for a while. Saved them with no issues, and placed them in a schematic. No issues. Upon restarting Kicad I am given the following style error:

9:07:43 PM: Library 'ThisLibrary' component load error Wrong DEF format in line 1714, skipped..
9:07:43 PM: Library 'Board-cache' component load error Wrong DEF format in line 313, skipped..

Name details removed for privacy. Anyway, Kicad isn't happy with the DEF line of this component, fine. I went over the details here (https://en.wikibooks.org/wiki/Kicad/file_formats#Description_of_DEF) on a sample component which I can load from the same library:

DEF OPA1644 U 0 20 Y Y 4 L N

Looks fine. Now on the line where Kicad complained about formatting issues:

DEF Power Transformer X 0 40 Y N 1 F N

Note the space in the component name Power Transformer. Naturally since the DEF line is space delimited, it would cause an error. But the schematic editor allowed me to choose this name for a component without generating an error or warning or replacing the space with an underscore.

I will test this problem on Linux as well to see if it happens on multiple platforms.

Version information:
Application: kicad
Version: 4.0.3-stable release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Related branches

Changed in kicad:
status: New → Fix Committed
Changed in kicad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers